Lightning 0.5: russian weekday names are shortened incorrectly

RESOLVED FIXED

Status

Mozilla Localizations
ru / Russian
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: Deniska, Assigned: Alexey Gubanov)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: 0.5 RC 1

Some of russian weekday names are shortened incorrectly in small calendar (part of thunderbird integration). Week view shows correctly shortened weekday names.

Previous version (0.3) had only one incorrect weekday name (Thursday).

Reproducible: Always
(Reporter)

Comment 1

11 years ago
Created attachment 267402 [details]
Incorrect weekday names

Incorrectly shortened weekday names are underlined.
(Reporter)

Updated

11 years ago
Version: unspecified → Lightning 0.5

Comment 2

11 years ago
The shortened weekday names look as specified by the Russian translation team:
http://lxr.mozilla.org/l10n-mozilla1.8/source/ru/calendar/chrome/calendar/dateFormat.properties#83
Assignee: nobody → unghost
Component: Lightning Only → ru / Russian
Product: Calendar → Mozilla Localizations
QA Contact: lightning → unghost
Summary: russian weekday names are shortened incorrectly → Lightning 0.5: russian weekday names are shortened incorrectly
Version: Lightning 0.5 → unspecified
Created attachment 267426 [details]
[sk] Incorrectly shortened weekday names

This affects also sk locale even though shortened weekday names are localized correctly in http://lxr.mozilla.org/l10n-mozilla1.8/source/sk/calendar/chrome/calendar/dateFormat.properties#83
See screenshot.
Reassigning to Russian Sunbird Localizer for triage, though considering comment #3, it looks like Sunbird core bug, not Russian l10n's.
Assignee: unghost → ragnaar

Comment 5

11 years ago
The bug in Sunbird (Bug 373350) will be fixed after release of Sunbird 0.5.

But for ru locale this bug is not effective because the dateFormat.properties specify the abbreviations for the day names with just one character.

If this bug is being confirmed by the Russian localizer and dateFormat.properties is updated it also requires Bug 373350 to be fixed.
Depends on: 373350
(Reporter)

Comment 6

11 years ago
As I can see, http://lxr.mozilla.org/l10n-mozilla1.8/source/ru/calendar/chrome/calendar/dateFormat.properties#83
has incorrect abbreviations for the day names (just like the screenshot).
"day.X.short" values are incorrect, while "day.X.Mmm" values are correct.
(Assignee)

Comment 7

11 years ago
One character in the weekdays names not my idea. I have changed translation after changes in  the English dateFormat.properties (look at the English file will see 1 character in some name too).

I can return former (2 symbolical) translation and commit in CVS.
(In reply to comment #6)
> As I can see,
> http://lxr.mozilla.org/l10n-mozilla1.8/source/ru/calendar/chrome/calendar/dateFormat.properties#83
> has incorrect abbreviations for the day names (just like the screenshot).
> "day.X.short" values are incorrect, while "day.X.Mmm" values are correct.
> 
Even if "day.X.short" in Russian will be fixed, it requires Bug 373350 to be fixed to make russian weekdays names show correctly.

(In reply to comment #7)
> I can return former (2 symbolical) translation and commit in CVS.
I think that will be best decision. 

Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 9

11 years ago
(In reply to comment #8)
> (In reply to comment #7)
> > I can return former (2 symbolical) translation and commit in CVS.
> I think that will be best decision. 
> 
Done. Translation returned and changes commited in CVS for both TRUNK and MOZILLA_1_8_BRANCH 
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.