Mochikit tests need to support multi-domain tests

RESOLVED FIXED

Status

Testing
Mochitest
RESOLVED FIXED
11 years ago
9 years ago

People

(Reporter: sicking, Assigned: sicking)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

We need to be able to write testcases that involves multiple domains. I suggest we simply listen on two ports, but serve the same content on both of them.
Created attachment 267670 [details] [diff] [review]
Patch to fix

This includes a minimal test to test that cross-domain stuff works as it should.
Assignee: nobody → jonas
Status: NEW → ASSIGNED
Attachment #267670 - Flags: review?(sayrer)

Updated

11 years ago
Attachment #267670 - Flags: review?(sayrer) → review+

Updated

11 years ago
Duplicate of this bug: 347765

Comment 3

11 years ago
Jonas, this is FIXED now, right?
This doesn't address a large class of things we need to test: subdomains, which are needed for document.domain testing.  In particular, for reasonable testing I think we need about the list of domains from bug 332179.
And yes, serving the same content on all of them is the way to go.
I'm working on adding proxy support to the server (no bug, yet), so with the right PAC I think you can "spoof" content on subdomains, different domains, different ports, etc.  This was maybe a quarter done the last I worked on it, but since that was pre-bug 367214 (and pre- the last patch, which had a fair number of significant-but-not-difficult changes from the previous patch) there's some merging to do.  It wasn't super-high on the priority list of things to do in my spare time (learning layout's higher at the moment), but I can bump it higher if it's important.
I'm marking this one FIXED though since we can do basic multi-domain testing. Filed bug 384192 for subdomains.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Flags: in-testsuite+
Moving a bunch of Core :: Testing bugs to Testing :: Mochitest to clear out the former, which is obsolete now that we have more specialized categories for such bugs; filter on the string "MochitestMmMm" to delete all these notifications.
Component: Testing → Mochitest
Flags: in-testsuite+
Product: Core → Testing
QA Contact: testing → mochitest
Version: Trunk → unspecified
You need to log in before you can comment on or make changes to this bug.