Closed Bug 383512 Opened 16 years ago Closed 16 years ago

Make gfx support text drawing onto any surface type

Categories

(Core Graveyard :: GFX: Win32, defect)

x86
Windows Vista
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: longsonr, Assigned: longsonr)

References

()

Details

(Keywords: hang, regression, testcase)

Attachments

(1 file, 2 obsolete files)

Attached patch patch (obsolete) — Splinter Review
No description provided.
Attachment #267494 - Flags: review?(roc)
Attached patch simplify ReleaseDC check (obsolete) — Splinter Review
Attachment #267494 - Attachment is obsolete: true
Attachment #267549 - Flags: review?(roc)
Attachment #267494 - Flags: review?(roc)
Comment on attachment 267549 [details] [diff] [review]
simplify ReleaseDC check

This is more Stuart's thing
Attachment #267549 - Flags: review?(roc) → review?(pavlov)
Not gonna block, but I really really would like to have this...
Flags: blocking1.9? → blocking1.9-
Whiteboard: [wanted-1.9]
Would you like to review it then?
Is the measurement result from GetDC(0) the same as that for the DC from the surface in all cases?  I'm particularly worried about printing; it seems quite possible that text measurement works differently there due to different hinting.  It's quite possible that it isn't different, though; I wouldn't be surprised if that's the case since Mac and Linux seem to do device-independent text measurement.

Actually, if the DC from GetDC(0) is just as good as any other DC, we should just do that unconditionally to simplify the code.
It's rather hard to tell as printing and print preview of any SVG has been broken on Windows for a long time now. On Windows SVG comes out really tiny. C.f. bug 314707 comment 16 although you can no longer build the trunk with --enable-default-toolkit=windows
Oh, right... that's bug 370006.
Here's an even simpler version of this patch... uses a helper class to manage obtaining the DC and the conversion.
Attachment #275631 - Flags: review?(pavlov)
Attachment #275631 - Flags: review?(pavlov) → review+
Attachment #267549 - Attachment is obsolete: true
Attachment #267549 - Flags: review?(pavlov)
Was checked in.
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
Flags: wanted1.9+
Whiteboard: [wanted-1.9]
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.