If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

No way to automatically forward messages in UTF-8

RESOLVED DUPLICATE of bug 301291

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 301291
10 years ago
10 years ago

People

(Reporter: Petr Hroudný, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: Thunderbird 2.0.0

It is not possible to send all mail in UTF-8 (like gmail can do).
In preferences, one can configure UTF-8 as default encoding for outgoing mails,
there's also an option to use this default character encoding on replies.
However, when a message is inline *forwarded*, it's by default forwarded in its original charset, unless the user changes encoding to UTF-8 manually for each message.

The best solution would be to rework the option "Use the default character encoding in replies" into "Use the default character encoding in replies and forwarded messages" so one can send *all* outgoing mail in UTF-8. Better yet,
there could be a single option "Send all mail in UTF-8".

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Updated

10 years ago
Severity: normal → enhancement
(Reporter)

Comment 1

10 years ago
Looked at mailnews/compose/src/nsMsgCompose.cpp

The code snippet providing the default charset for replies is quite strightforward:

      // use send_default_charset if reply_in_default_charset is on.
      nsCOMPtr<nsIPrefBranch> prefs (do_GetService(NS_PREFSERVICE_CONTRACTID));
      if (prefs)
      {
        PRBool replyInDefault = PR_FALSE;
        prefs->GetBoolPref("mailnews.reply_in_default_charset",
                           &replyInDefault);
        if (replyInDefault) {
          nsXPIDLString str;
          NS_GetLocalizedUnicharPreferenceWithDefault(prefs, "mailnews.send_defa
ult_charset",
                                                      EmptyString(), str);
          if (!str.IsEmpty())
            LossyCopyUTF16toASCII(str, charset);
        }
      }

Would it be possible to put identical code into function which handles inline-forwarding?

Thanks, Petr
(Reporter)

Comment 2

10 years ago
Requeued into Message Compose and changed Severity to normal. Most other mail clients do the same for replies and forwards, so current behaviour of Thunderbird is non-standard and confusing.
Severity: enhancement → normal
Component: Preferences → Message Compose Window
Version: unspecified → 2.0
QA Contact: preferences → message-compose
(Reporter)

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 301291
You need to log in before you can comment on or make changes to this bug.