Last Comment Bug 384748 - xpidl can generate garbage .java filenames
: xpidl can generate garbage .java filenames
Status: RESOLVED FIXED
[needs testcase]
: fixed1.8.1.8
Product: Core Graveyard
Classification: Graveyard
Component: Java to XPCOM Bridge (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Andrew Schultz
:
Mentors:
: 390705 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-16 21:44 PDT by Andrew Schultz
Modified: 2014-09-24 05:43 PDT (History)
3 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
patch (873 bytes, patch)
2007-06-16 21:44 PDT, Andrew Schultz
jhpedemonte: review+
dveditz: approval1.8.1.8+
Details | Diff | Splinter Review

Description Andrew Schultz 2007-06-16 21:44:58 PDT
Created attachment 268655 [details] [diff] [review]
patch

xpidl_java's interface_declaration can construct the output file from an uninitialized char* if IDL filename has no '/'.
Comment 1 Andrew Schultz 2007-06-18 21:08:38 PDT
FIXED
Comment 2 jhp (no longer active) 2007-08-06 14:22:24 PDT
*** Bug 390705 has been marked as a duplicate of this bug. ***
Comment 3 jhp (no longer active) 2007-08-06 14:24:55 PDT
Comment on attachment 268655 [details] [diff] [review]
patch

Asking for 1.8.1.7 approval.  This is a low risk change that fixes a bug when using XPIDL to generate Java interface files.
Comment 4 Marcus Better 2007-08-07 00:25:22 PDT
Sorry about the duplicate report.

As a minor comment, this code:

     strcat(outname, interface_name);
     strcat(outname, ".java");

may possibly overflow the outname buffer. My patch in bug 390705 tries to be more careful there.
Comment 5 Daniel Veditz [:dveditz] 2007-08-29 15:34:00 PDT
Comment on attachment 268655 [details] [diff] [review]
patch

approved for 1.8.1.7, a=dveditz for release-drivers

Note You need to log in before you can comment on or make changes to this bug.