Links loaded from different domains in a frame fail to load the third time.

VERIFIED DUPLICATE of bug 364461

Status

()

Core
Document Navigation
--
major
VERIFIED DUPLICATE of bug 364461
11 years ago
6 years ago

People

(Reporter: stephend, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
Build ID: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a6pre) Gecko/20070618 Minefield/3.0a6pre

Checking on a regression range right now...

Not sure this is in the right component; punt as needed.

Summary: Links loaded from different domains in a frame fail to load the third time.

Steps to Reproduce:

1. Load http://images.google.com/images?svnum=10&um=1&hl=en&safe=off&q=mozilla&btnG=Search+Images
2. Click on the first image there (Mozilla is a global community ...
390 x 261 - 96k - jpg
mozilla2.org)
3. Once the page finished loading, click Back
4. If the links work now, click the image again, then Back again

Expected Results:

You should be able to load all of the links within the Google Images frame "infinitely"

Actual Results:

Although a Reload fixes this temporarily, after the first two loads of the image/links, we fail
(Reporter)

Comment 1

11 years ago
This regressed between 2007-06-14 and 2007-06-15; is bug 353732 a probable cause?
What are the hours for those builds?
(Reporter)

Comment 3

11 years ago
(In reply to comment #2)
> What are the hours for those builds?

2007-06-14-04-trunk and 2007-06-15-04-trunk 

The patch for bug 371360 is the most likely cause in that range, I think.
So... I can't reproduce this (with a build pulled on MOZ_CO_DATE="Sat Jun 16 00:28:35 CDT 2007").
I tested both Seamonkey and Firefox.
This is how I can reproduce it in SeaMonkey:
<CTho> 1. http://www.google.com
<CTho> 2. click images
<CTho> 3. type mozilla, click search imaes
<CTho> 4. click the first result
<CTho> 5. click "see full-size image"
<CTho> 6. click the back button.
<CTho> 7. click any other link you see - none work
Minimalish testcase:

data:text/html,<iframe src="data:text/html,<a href='http://www.google.com' target='_main'>Click me, hit back, click me again"></iframe>

The key is that the load kills the frameset.  This is _so_ a longstanding bfache bug...
Component: DOM → History: Session
OS: Windows Vista → All
QA Contact: general → history.session
Hardware: PC → All
Or even simpler:

data:text/html,<iframe src="data:text/html,<a href='data:text/plain,aaa' target='_main'>Click me, hit back, click me again"></iframe>
Created attachment 268912 [details]
Testcase showing that this has been a problem with bfcache all along
And in fact, this is a duplicate.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 364461
(Reporter)

Comment 14

11 years ago
Verified DUP; thanks for all your hard work and patience, Boris.
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: History: Session → Document Navigation
QA Contact: history.session → docshell
You need to log in before you can comment on or make changes to this bug.