mail downloaded with "fetch headers only" on and automatically marked as junk is automatically deleted from server if user marks mail as not junk and attempts to download rest of message without moving message to a folder other than trash

RESOLVED DUPLICATE of bug 287728

Status

--
minor
RESOLVED DUPLICATE of bug 287728
11 years ago
11 years ago

People

(Reporter: molasses, Unassigned)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: 2.0.0.4 (20070604)

I have my account settings set to
Automatically download new messages
Fetch headers only
Leave messages on server --> until I delete them
Empty trash on exit

My adaptive junk mail controls are ENABLED
New junk messages are automatically moved to Trash on thisaccount (not my global trash)

If I click into my trash folder, click "this is not junk," then click to download the message - blam.  Message gone off server. 

Reproducible: Always

Steps to Reproduce:
Set account settings to:

Automatically download new messages
Fetch headers only
Leave messages on server --> until I delete them
Empty trash on exit

Enable adaptive junk mail controls.
Set new junk messages to be automatically moved to Trash on thisaccount (not global trash)

Receive mail that gets marked as junk.

Click into Trash folder, click "this is not junk," then click to download the message - blam.  Message gone off server.
Actual Results:  
message gone.

Expected Results:  
message gets moved to inbox (at least I would hope that would happen, but that doesn't happen, either) and then downloaded
(Reporter)

Updated

11 years ago
Version: unspecified → 2.0

Comment 1

11 years ago
I would guess the problem is you have it set to move junk to Trash (normally that's "delete it"). Does it work fine if you set it to use a Junk folder?
(Reporter)

Comment 2

11 years ago
(In reply to comment #1)
> I would guess the problem is you have it set to move junk to Trash (normally
> that's "delete it"). Does it work fine if you set it to use a Junk folder?
> 

Well, I've tested it a few times now, and yes, it works normally if you use a Junk (or other) folder.  But... but... but... I don't wanna!  :-)  Besides, it is still unexpected and unwelcome behavior.  It is, however, a minor bug, as there is a very simple workaround and most people will never run into it anyways.

Comment 3

11 years ago
dupe or simlar to bug 287728?
(Reporter)

Comment 4

11 years ago
(In reply to comment #1)
> I would guess the problem is you have it set to move junk to Trash (normally
> that's "delete it"). Does it work fine if you set it to use a Junk folder?
> 

I guess my main problem with this bug is that "empty Trash on exit," to me, ought to mean that when you put something in the trash it functions in the default manner of the Windows recycle bin - which is, anything you put in there remains in there until you empty the trash.  If you don't exit the program, the things you put in the trash ought to remain in the trash.

Comment 5

11 years ago
(In reply to comment #3)
> dupe or simlar to bug 287728?

most definitely a dupe. see my comment there.

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 287728
You need to log in before you can comment on or make changes to this bug.