Reminder /alarm dialog doesn't show times in configured timezone

VERIFIED FIXED in 0.7

Status

defect
VERIFIED FIXED
12 years ago
11 years ago

People

(Reporter: software.architekt, Assigned: dbo)

Tracking

unspecified
Bug Flags:
blocking-calendar0.7 +

Details

Attachments

(1 attachment)

Reporter

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: 2007061403

My timezone is Europe/Berlin (PC timezone and Lightning timezone). If I get an invitation from Outlook, than the date/time (11:15 AM) of the event is set correct. The alarm fires at the correct time (11 AM), too. But the time of the event in the alarm dialog isn't correct. In my case the alarm dialog sets the event 2 hours to early (09:15 AM).

Reproducible: Always

Steps to Reproduce:
1.
2.
3.



BEGIN:VCALENDAR
PRODID:-//Microsoft Corporation//Outlook 11.0 MIMEDIR//EN
VERSION:2.0
METHOD:REQUEST
BEGIN:VEVENT
ATTENDEE;ROLE=REQ-PARTICIPANT;RSVP=TRUE:MAILTO:andreas.bugzilla@onlinehome.de
ORGANIZER:MAILTO:andreas.bugzilla@onlinehome.de
DTSTART:20070620T091500Z
DTEND:20070620T094500Z
LOCATION:hier
TRANSP:OPAQUE
SEQUENCE:0
UID:040000008200E00074C5B7101A82E00800000000C0634C2629B3C7010000000000000000100
 0000084BCE46C99A76349B88F8D040622CCAB
DTSTAMP:20070620T085252Z
DESCRIPTION:Zeit: Mittwoch\, 20. Juni 2007 11:15-11:45 (GMT+01:00)
  Amsterdam\, Berlin\, Bern\, Rom\, Stockholm\, Wien.\nOrt:
  hier\n\n*~*~*~*~*~*~*~*~*~*\n\n\n
SUMMARY:Test
PRIORITY:5
X-MICROSOFT-CDO-IMPORTANCE:1
CLASS:PUBLIC
BEGIN:VALARM
TRIGGER:-PT15M
ACTION:DISPLAY
DESCRIPTION:Reminder
END:VALARM
END:VEVENT
END:VCALENDAR

Comment 1

12 years ago
I have successfully duplicated this behavior (US English / New York US Timezone), albeit with a different offset. Alarm fires at right time, but the dialog consistently displays a time four hours in the future. Bad math calculating from GMT perhaps?
This looks like just a reminder dialog issue and is not related to invitations. The issue can be reproduced by e.g. creating an event with alarm in timezone A and changing the timezone to B in Sunbird preferences afterwards. When the alarm fires the dialog shows the original time and not the converted time as done in the views or tooltips.

Confirmed using Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.8pre) Gecko/20071016 Sunbird/0.7
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Summary: Alarms of invitations not shown in correct timezone → Reminder /alarm dialog doesn't show times in configured timezone
Duplicate of this bug: 399565
Assignee

Comment 4

12 years ago
Posted patch fixSplinter Review
Assignee: nobody → daniel.boelzle
Status: NEW → ASSIGNED
Attachment #285340 - Flags: review?(ssitter)
Comment on attachment 285340 [details] [diff] [review]
fix

r=sitter
Attachment #285340 - Flags: review?(ssitter) → review+
Assignee

Updated

12 years ago
Keywords: checkin-needed
Whiteboard: [checkin-needed after 0.7]
As we are going to have a RC3 we should consider taking this fix too.
Flags: blocking-calendar0.7?

Comment 7

12 years ago
This looks to be low risk and a great fix.

Let's take it for RC3 in addition to bug 400407
Flags: blocking-calendar0.7? → blocking-calendar0.7+

Comment 8

12 years ago
Checked in on branch and trunk.  --> Fixed
*** Looking for modified files... 
cvs -n update calendar/base/content/calendar-alarm-dialog.js
M calendar/base/content/calendar-alarm-dialog.js

--------------------------------------------------------------------
*** Modified Files:
  calendar/base/content/calendar-alarm-dialog.js
*** Working Branch:
  MOZILLA_1_8_BRANCH
*** Committing to Branches:
  HEAD
  MOZILLA_1_8_BRANCH
*** Checking for conflicts on HEAD... 
cvs -n update -A calendar/base/content/calendar-alarm-dialog.js
RCS file: /cvsroot/mozilla/calendar/base/content/calendar-alarm-dialog.js,v
retrieving revision 1.2.2.16
retrieving revision 1.18
Merging differences between 1.2.2.16 and 1.18 into calendar-alarm-dialog.js
M calendar/base/content/calendar-alarm-dialog.js

--------------------------------------------------------------------
*** Checking for conflicts on MOZILLA_1_8_BRANCH... 
cvs -n update -r MOZILLA_1_8_BRANCH calendar/base/content/calendar-alarm-dialog.js
M calendar/base/content/calendar-alarm-dialog.js

--------------------------------------------------------------------
No conflicts found; good.
*** Committing to MOZILLA_1_8_BRANCH... 
cvs commit -m Bug 385155 reviewed by ssitter, patch by daniel B. calendar/base/content/calendar-alarm-dialog.js
Checking in calendar/base/content/calendar-alarm-dialog.js;
/cvsroot/mozilla/calendar/base/content/calendar-alarm-dialog.js,v  <--  calendar-alarm-dialog.js
new revision: 1.2.2.17; previous revision: 1.2.2.16
done

--------------------------------------------------------------------
*** Extracting commit info.
  calendar/base/content/calendar-alarm-dialog.js: 1.2.2.16 -> 1.2.2.17.
*** Merging calendar/base/content/calendar-alarm-dialog.js changes from 1.2.2.16 to 1.2.2.17 into HEAD... 
cvs update -A -j 1.2.2.16 -j 1.2.2.17 calendar/base/content/calendar-alarm-dialog.js
U calendar/base/content/calendar-alarm-dialog.js
RCS file: /cvsroot/mozilla/calendar/base/content/calendar-alarm-dialog.js,v
retrieving revision 1.2.2.16
retrieving revision 1.2.2.17
Merging differences between 1.2.2.16 and 1.2.2.17 into calendar-alarm-dialog.js

--------------------------------------------------------------------
*** Committing calendar/base/content/calendar-alarm-dialog.js on HEAD... 
cvs commit -m Bug 385155 reviewed by ssitter, patch by daniel B. calendar/base/content/calendar-alarm-dialog.js
Checking in calendar/base/content/calendar-alarm-dialog.js;
/cvsroot/mozilla/calendar/base/content/calendar-alarm-dialog.js,v  <--  calendar-alarm-dialog.js
new revision: 1.19; previous revision: 1.18
done

--------------------------------------------------------------------
*** Returning your tree to its original working branch... 
cvs update -r MOZILLA_1_8_BRANCH calendar/base/content/calendar-alarm-dialog.js
P calendar/base/content/calendar-alarm-dialog.js

--------------------------------------------------------------------
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
To be contained in RC3 we need a checkin on SUNBIRD_0_7_BRANCH too.
Assignee

Comment 10

12 years ago
Checked in on SUNBIRD_0_7_BRANCH.

Updated

12 years ago
Keywords: checkin-needed
Whiteboard: [checkin-needed after 0.7]
Target Milestone: --- → 0.7

Comment 11

12 years ago
Times are now shown in the configured time zone in the alarm dialog but still in UTC in the edit event dialog (lightning 2007102304). To my opinion, it can not be demanded of normal users that they know about UTC and the exact offset of their current time zone.
(In reply to comment #11)
AFAIK times are only shown in original timezone (this case UTC) in the Event dialog if you enabled it. Disable Option->Timezone in the Event dialog to show the times in local time.

Comment 13

12 years ago
(In reply to comment #12)
Thanks and sorry, I wasn't aware of this option.

Comment 14

12 years ago
Checked in latest nightly build -> task is fixed and verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.