Closed Bug 385162 Opened 15 years ago Closed 14 years ago

Sending with "Fixed Width" HTML format ignored. Mail is sent as plain text.

Categories

(Thunderbird :: Message Compose Window, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 414299

People

(Reporter: rduke15, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.12) Gecko/20070508 Firefox/1.5.0.12
Build Identifier: Thunderbird 2.0.0.4 (Windows/20070604)

 

Reproducible: Always

Steps to Reproduce:
1.Compose a mail with one paragraph formatted as "Fixed Width"
2.Send the mail
3.
Actual Results:  
The mail is sent as plain text and the "Fixed Width" formatting is lost.
The "HTML mail" dialog doesn't come up to ask whether to send the mail as Plain, HTML or Both. Basically "Fixed Width" is dropped and the mail treated as a plain text email.

Expected Results:  
It should be treated as the HTML mail it was.

A workaround is to also set a color on some text in the email.

Are there other HTML tags which get silently dropped?

This is a (mild) form of data loss bug. The formatting is silently dropped, and users may not even notice that their formatting was lost. Fixed width formatting is usually important when it is used, and dropping it leads to these parts being very difficult to read if the recipient uses variable fonts as his default display (which is almost everybody's case).
This might really be a "Core" bug rather than Thunderbird only, but I don't know.
Confirmed in 2.0.0.9 (20071031).

This garbled an important work-related message on me, and I didn't notice until I got the response.

The Drafts folder shows the message formatted properly, but when sent, it is converted to text/plain, stripping the formatting.
Yep, it's a core issue - duping forward, since the newer one already picked up more information.
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 414299
You need to log in before you can comment on or make changes to this bug.