Closed Bug 385249 Opened 17 years ago Closed 14 years ago

Items overrun the boundary on Lightning options tabs

Categories

(Calendar :: Preferences, defect, P3)

Lightning 0.5
x86
Windows XP

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: jfisher, Assigned: berend.cornelius09)

References

Details

Attachments

(4 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: 2007061403

In options window all text and fields overrun to the right.  Easily reproduceable running t-bird 1.5 and the .5rc2 lighting.

From within t-bird go to tools pull down, click options.  then click lightning.  Click alarms you can se preview and the down tabs for all alarm settings overrun to the right (i.e. you cant see the whole item)

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Actual Results:  
um self explanitory is a visual bug not function bug.

Expected Results:  
should be able to see ALL of the useable items.

thats about it
Version: unspecified → Lightning 0.5
Lightning can't change the width of the Thunderbird preference window. I can confirm this at least for en-US Thunderbird 1.5 and en-US Lightning 0.5. Other locales might differ.

But I see no problems using en-US Thunderbird 2.0 and en-US Lightning 0.5.
I see the views tab of the Lightning options being not high enough with en-US Tb 2.0 and recent Lightning 0.7pre nightly on WinXP with classic theme.
In my case, the right side of Lightning's options are truncated.  This is with the current nightly of Lightning, Thunderbird 2.0.0.6, WinXP classic theme, large DPI display fonts, and a system-wide font family of Courier New.

Firefox and Thunderbird both have these problems on my computer and I know that there is at least one Firefox bug in Bugzilla.

Jere, I fixed this by going to my Thunderbird profile folder.  In the Chrome folder, edit a file called UserChrome.css (create the file if it doesn't already exist), and add the following code:

#MailPreferences
{
     width: 800px !important;
     height: 600px !important;
}

Then save the file and restart Thunderbird.  You can tweak the width and the height to your satisfaction.
So how to fix this properly?
Filing a bug for Thunderbird to request to resize that window or make the preference window rezisable?
Summary: In lightning clicking the lightning tab in options, items overrun the boundary → Items overrun the boundary on Lightning options tabs
Confirming this bug based on the duplicates.
Severity: trivial → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
This is still on for TB 2.0.0.14 Lightning 0.8

(In reply to comment #5)
> So how to fix this properly?
the easiest seams to be reorg of options so that they fit in that limited space.

also as workaround css I find enough to put:

#MailPreferences { height: 500px !important; }

or
#MailPreferences { height: 44em !important; }

[de default style shows w 44em/h 38em]


Flags: tb-integration?
Flags: tb-integration? → tb-integration+
Is this Windows only? It looks good on Mac, what about other platforms?
(In reply to comment #11)
> Is this Windows only? It looks good on Mac, what about other platforms?

Maybe it is related with Thunderbird default theme (with silvermel theme there is scrollbar)
Attached image Silvermel theme
Priority: -- → P3
Assignee: nobody → Berend.Cornelius
I cannot reproduce this issue in the latest nightly anymore, wheareas I had no problem to reproduce it in Lightning 0.9 (under Windows). Also I noticed that the preference dialog  is - in Windows only - not resizable anymore.
Neither me nor Andreas could reproduce this issue anymore, so I am declaring this as resolved
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → WORKSFORME
Easily reproducible for me using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20081214 Lightning/1.0pre Shredder/3.0b2pre. Still seeing the behavior I reported in comment#3.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Martin, thanks for your 'use windows classic theme' hint. Now it's possible for me to reproduce this issue. The bug is fixed with the default windows XP desktop theme.
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b3pre) Gecko/20081212 Lightning/1.0pre Shredder/3.0b2pre ID:20081212032953

WFM (vista)
Status: REOPENED → NEW
WFM on linux. Can anyone on windows xp and mac reproduce this issue?
Mozilla/5.0 (Windows; U; Windows NT 5.1; cs; rv:1.9.1.8) Gecko/20100216 Lightning/1.0b1 Thunderbird/3.0.2

Looks OK on Windows XP
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.7) Gecko/20100111 Lightning/1.0b1 Thunderbird/3.0.1 ID:20100111101938

WFM vista
Thanks for testing, looks like this is WFM.
Status: NEW → RESOLVED
Closed: 15 years ago14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.