Saving draft with characters from wrong character set prompts "Sent in UTF-8, Send anyway or Cancel", when it should prompt to save.

RESOLVED DUPLICATE of bug 328938

Status

--
minor
RESOLVED DUPLICATE of bug 328938
12 years ago
12 years ago

People

(Reporter: rtshilston, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: 2.0.0.4 (20070604)

As in summary / how to reproduce

Reproducible: Always

Steps to Reproduce:
1. Compose new message
2. Go to Options, Character Encoding, and ensure ISO-8859-1 is selected
3. Go to www.bbcrussian.com, copy some Russian text (eg Обновлено), and paste it into the body of the Compose window.
4. Choose File, Save

Actual Results:  
You'll see a dialog which says:

The message you composed contains characters not found in the selected Character Encoding... 
<Send in UTF-8> <Send anyway> <Cancel>

Expected Results:  
The prompts to "Send" are wrong.  They should say "Save".

It's possible this only happens if your drafts folder is on an IMAP server.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 328938
You need to log in before you can comment on or make changes to this bug.