Go Button and Search-Go Button can't be removed/hidden by customization

RESOLVED DUPLICATE of bug 378983

Status

()

Firefox
Toolbars and Customization
RESOLVED DUPLICATE of bug 378983
11 years ago
4 years ago

People

(Reporter: cyberbrain_of_nn, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4

Just upgraded from firefox 1.5 to 2.0.0.4. The first thing that i noticed was that there were a new bug in the userinterface, namely when using the customize toolbar:

- when removing the go-button the url-bar is also removed
- when removing the search-go-button (magnifying glass) the search-bar is also removed

In fact, it seems to be impossible to remove those two buttons, without also removing their associated bars (unless some config hacking is done)!

I searched the forums and found several topics about this, but surprisingly i could find no bug reports about it on bugzilla. Sorry if this has already been submitted.

(also, there are close-buttons on all tabs now, which it doesn't seem to be possible to remove from the preferences - quite distracting)

Reproducible: Always

Steps to Reproduce:
1. Go to the Customize Toolbar window.
2. drag the go button away
3. drag the search go button away
Actual Results:  
The buttons are gone, but the urlbar and searchbar are also gone!

Expected Results:  
The buttons should be gone, but the bars should stay.

workaround:
----------

As i learned from the forums, it's possible to workaround the bug with some config hacking:

To disable the Go-button and Search-Go-button:   

    put this in userChrome.css:

    #go-button-stack, .search-go-button-stack {
      display: none !important;
    }    

    (the go-button can also be disabled in about:config by setting 
     browser.urlbar.hideGoButton to true. However, when a new window opens the 
     button is shown for about 0.5 seconds before it disappears. 
     There doesn't seem to be an entry for disabling the search-go-button.)

To disable the close buttons on all except the active tab:
    go to about:config and set browser.tabs.closeButtons to 0

Updated

11 years ago
Whiteboard: DUPEME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 378983

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.