HTML <textarea> on trunk has less width than col= attribute states

RESOLVED WORKSFORME

Status

()

P5
normal
RESOLVED WORKSFORME
12 years ago
11 years ago

People

(Reporter: kairo, Unassigned)

Tracking

({regression, testcase})

Trunk
x86
Linux
regression, testcase
Points:
---
Bug Flags:
blocking1.9 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

12 years ago
Build identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a6pre) Gecko/2007062101 SeaMonkey/2.0a1pre

On my local home page, I have a HTML <textarea name="notes" rows="10" cols="65"> for taking quick notes. While on branch, 65 characters can be shown in its width (actually it even allows 66), trunk only shows 49 characters of width. I have a comparison screenshot available, but I think I'll do a reduced testcase and attach that and a screen shot of that instead of my local page.
(Reporter)

Comment 1

12 years ago
Created attachment 269424 [details]
testcase: a texarea and a text input
(Reporter)

Comment 2

12 years ago
Created attachment 269429 [details]
screenshot of testcase on branch and trunk

And here's a comparison screenshot of 1.8 branch and my current trunk build.
(Reporter)

Comment 3

12 years ago
Created attachment 269432 [details]
screenshot of testcase on branch and trunk  

Sorry, I just realized I had a different default font set for the normal text surrounding the form inputs when taking the trunk screenshot (Vera vs. Arial).

Now both screen shots are taken with fonts set to the same sizes of the same fonts (Arial for sans-serif/default, Vera Sans Mono for Monospace).
Attachment #269429 - Attachment is obsolete: true

Updated

12 years ago
Keywords: regression, testcase
(Reporter)

Comment 4

11 years ago
From bug 388179 comment #0:
Boris Zbarsky   2007-07-14 14:07:10 PDT

This is the pango equivalent of bug 364300.  I'm seeing the max-advance end up
twice as big as the ave char width, due to CJK chars.

I wouldn't be surprised if Windows has a similar issue...
Component: Layout: Form Controls → GFX: Thebes
QA Contact: layout.form-controls → thebes
(Reporter)

Updated

11 years ago
Duplicate of this bug: 388179
Flags: blocking1.9?
Flags: blocking1.9? → blocking1.9+

Updated

11 years ago
Priority: -- → P3

Comment 6

11 years ago
this seems to go away for me with the patch in 399813.  can anyone else verify?

Comment 7

11 years ago
i can't reproduce this with or without my patch.  Can anyone actually still reproduce this?
Priority: P3 → P5
(Reporter)

Comment 8

11 years ago
Actually, you're right, it looks OK now... and I don't even know when it got fixed.
The textarea seems correctly sized in the testcase now, the input looks a bit too short though, but I guess that's bug 399813 as you mentioned.

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.