RSS feed icons missing/broken in the URL bar

VERIFIED FIXED in Firefox 3 alpha6

Status

()

--
major
VERIFIED FIXED
12 years ago
11 years ago

People

(Reporter: stephend, Assigned: Ehsan)

Tracking

Trunk
Firefox 3 alpha6
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
Build ID: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a6pre) Gecko/20070624 Minefield/3.0a6pre (Tinderbox build; very recent).

Summary: RSS feed icons are missing/broken in the URL bar

Bug 383746 broke this, no doubt.

Steps to Reproduce:

1. Load a site, such as Netscape.com, which specifies it RSS feed:

<link rel="alternate" type="application/rss+xml" title="Netscape" href="http://www.netscape.com/rss/" />

2. Look at the URL bar

Expected Results:

RSS feed icon appears, and upon clicking either presents a choice of feeds (if there are multiple) or goes straight to its feed page so you can subscribe.

Actual Results:

No icon appears at all.
(Reporter)

Comment 1

12 years ago
I might be missing the changes to browser.js mentioned in https://bugzilla.mozilla.org/show_bug.cgi?id=383746#c14, but I grabbed this from ftp://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/fx-win32-tbox-trunk/ and its full build ID is 2007-06-24-20...
(Assignee)

Comment 2

12 years ago
Yeah, the bug is caused by the checkin from bug 383746.  I'll be posting a patch soonish.
Status: NEW → ASSIGNED
OS: Windows Vista → All
Hardware: PC → All
Target Milestone: --- → Firefox 3 alpha6
(Assignee)

Comment 3

12 years ago
Created attachment 269629 [details] [diff] [review]
Patch to fix the problem

This way a mistake on my part on bug 383746.  This patch fixes the problem.  A quick review and checkin would be appreciated.

Sorry for the problem.  :-(
Attachment #269629 - Flags: review?(mano)
Comment on attachment 269629 [details] [diff] [review]
Patch to fix the problem

r=mano
Attachment #269629 - Flags: review?(mano) → review+
mozilla/browser/base/content/browser.js 1.803
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

12 years ago
Verified FIXED in Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a6pre) Gecko/20070625 Minefield/3.0a6pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.