Support Jabber (XMPP) in addition to Mail and News

REOPENED
Unassigned

Status

enhancement
REOPENED
12 years ago
2 years ago

People

(Reporter: da+mozbugzilla, Unassigned)

Tracking

unspecified
Bug Flags:
wanted-thunderbird3 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; de; rv:1.8.0.12) Gecko/20070508 Firefox/1.5.0.12
Build Identifier: 

XMPP (Jabber) is a messaging protocol that supports email-like messages (user@domain addresses, subject, body, threads, etc.). It would make sense to have this protocol supported in mail clients such as Thunderbird.
When creating a new account, XMPP would be an available option just as POP for example.
The fact that the messages are not sent via SMTP but via XMPP (using the same connection used for receiving messages) makes it somewhat tricky. For example, if the user tries to send a message via XMPP and TB receives an error because the recipient address is smtp-only, it should propose to resend the message via one of the user's smtp-compatible mail accounts.

XMPP supports also messages of type "chat". There are probably neat ways to integrate this in the interface (e.g. "start a chat from this message"), be it in the base program or thanks to an extension.

In a more general way, integration between Jabber and regular email can be very interesting. The GMail web interface already proposes such an interaction, but breaking the barrier in a desktop program such as Thunderbird would offer even more possibilities. The "ICQ-like" way of thinking about Jabber (contact-list, double-click, chat, sometimes message history) is not the only possibility, and a mail-like approach makes sense.

Reproducible: Always

Comment 1

12 years ago
An interesting first step would be to show XMPP presence (with "click-to-chat") if you can associate a JabberID with an email address either through (1) address book integration or (2) the Jabber-ID email header.
(Reporter)

Comment 3

12 years ago
> When creating a new account, XMPP would be an available option just as POP for
example.

Actually, since the Jabber system, just like the News system, is a separate network, choosing "Jabber" for the type of account should not be proposed in the mail-retrieving protocol selection (POP/IMAP) as I suggested before, but rather in the account type selection: Mail/News/Jabber. This would also avoid confusion for the user.
(Reporter)

Updated

12 years ago
Summary: Support XMPP in addition to POP/SMTP and IMAP/SMTP → Support Jabber (XMPP) in addition to Mail and News

Comment 4

12 years ago
Maybe you know it, maybe you don't. There is already an extension for Thunderbird for XMPP -> http://dev.hyperstruct.net/xmpp4moz
There is also Sameplace -> http://dev.hyperstruct.net/xmpp4moz/wiki/LocalApplicationSamePlaceSuite

I installed those extensions but atm they are not really good to use. A Systray is also needed imo.

Comment 5

12 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

12 years ago
(In reply to comment #4)
> Maybe you know it, maybe you don't. There is already an extension for
> Thunderbird for XMPP -> http://dev.hyperstruct.net/xmpp4moz

The Thunderbird port was done in the context of a thesis project at
CDG (http://cdg.di.uniba.it).  Previously they had supported
development of JabberPresence
(https://addons.mozilla.org/en-US/thunderbird/addon/867,
http://cde.di.uniba.it/projects/presence-ext/).

More ideas relevant to this bug were filed by Fabio Calefato
(Ph.D. at CDG) here:
http://dev.hyperstruct.net/xmpp4moz/query?reporter=%7Efcalefato&order=priority

> There is also Sameplace ->
> http://dev.hyperstruct.net/xmpp4moz/wiki/LocalApplicationSamePlaceSuite
> 
> I installed those extensions but atm they are not really good to use. A Systray
> is also needed imo.

Please consider taking a moment to report the issues you encountered!
(Regarding systray also see bug 325353 and bug 208923 here.)  Thanks.

Comment 7

12 years ago
The SIP/SIMPLE Cockatoo extension for Thunderbird could be used as a base for the GUI. <http://cockatoo.mozdev.org/>
Flags: wanted-thunderbird3?

Comment 8

11 years ago
This is a dumb enhancement to thunderbird email and INSTANT messaging are  pretty different   but if you want an XUL IM client then go here. http://www.instantbird.com/  ...
wanted‑thunderbird3-; patches welcome though.
Flags: wanted-thunderbird3? → wanted-thunderbird3-

Comment 10

11 years ago
(In reply to comment #8)
> This is a dumb enhancement to thunderbird email and INSTANT messaging are 
> pretty different   but if you want an XUL IM client then go here.
> http://www.instantbird.com/  ...

I don't know that it is such a stupid idea.

1) Contact information is already available via the address book.
2) IM is just a synchronous form of email.
3) Conversations could traverse IM/email
4) XMPP is an open standard, and supported by a number providers
5) Many people sit down, fire up their mail client, then fire up their IM client. 

It all seems very logical to me.  I do think that it might make more sense as an extension though, not baked into Thunderbird.  Maybe you can make Instantbird into an extension/standalone application, just like Lightning/Sunbird.

Comment 11

11 years ago
Instantbird has one advantage over Sameplace because it is an XULRunner application.  This will place a workload on it's developers to keep it at the same XULRunner core development level as Tbird if the two were to share one common XULRunner installation.

Instantbird is uses the libpurple IM engine that was mentioned in discussions in mozilla.dev.apps.thunderbird. A point I made during that discussion is development of interfaces which were third party developer friendly would be key to proposals such as Jabber/IM/IRC.

I would include solidification of the Tab Interface as being a big step to bring the additional messaging methods into the main Tbird window.
(In reply to comment #11)
> I would include solidification of the Tab Interface as being a big step to
> bring the additional messaging methods into the main Tbird window.

+1

...and with the benefit of having one application less running, combined contacts and history.

Comment 13

11 years ago
InstantBird is just a bad idea because it extends and publicises the use of proprietary protocols, thus deeply fragmenting and polluting the internet for a long time. Besides, the libpurple library has really poor open standards support.

Proprietary protocols just must die, and XMPP is the solution. It is already widely adopted on the internet worldwide, an ever increasing 50-100 millions users alone, and IT industry leaders like Adobe, Cisco, Oracle, Sun, IBM, Nokia, HP, Apple, AOL, Yahoo!, RedHat/JBoss, Yandex, and more!

Mozilla Messaging can help the internet-wide instant messaging and presence arena, just like Mozilla Foundation and Corporation successfully re-launched the wind of open standards on the web, worldwide.

SamePlace and OneTeam are far better ideas, because the are XUL/XULRunner-based XMPP clients.

http://www.sameplace.cc/
http://www.process-one.net/en/oneteam/

A Thunderbird extension could be written over other code bases, like Psi/Iris (C++) and Gajim (Python).

http://psi-im.org/
http://www.gajim.org/

The tab interface including e-mail and Jabber is already in place in Zimbra for example, this might inspire:

An organization should provide both an e-mail server and an Jabber server, with the same address being user@domain.tld:
- mailto:user@domain.tld
- xmpp:user@domain.tld

In my former company, I was using Thunderbird with SamePlace in one interface, with only one address. I could chat and read/write e-mails, and switch from one to another, depending on the contact's presence and availability.

Jabber/XMPP in Thunderbird: that's a KILLER FEATURE.

Comment 14

10 years ago
Now that XMPP is climbing up to the stars, a native XPCOM component for XMPP common to Thunderbird and Firefox would be really great.

Perhaps XMPP4MOZ could become part of the official native API ?

Bard, what do you think ?

Comment 15

8 years ago
XMPP would be awesome as would be SIMPLE
starting tonight http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-comm-central/ will contain xmpp , irc and Facebook.  make sure to test it and file bugs into the Thunderbird/Instant Messaging component.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 714733

Comment 17

7 years ago
(In reply to Ludovic Hirlimann [:Usul] from comment #16)
> starting tonight
> http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-comm-
> central/ will contain xmpp , irc and Facebook.  make sure to test it and
> file bugs into the Thunderbird/Instant Messaging component.
> 
> *** This bug has been marked as a duplicate of bug 714733 ***

Why the lastest nightly build of Thunderbird doesn't support other XMPP servers than Google?
I use the Fritalk XMPP server, (fritalk.com & fritalk.org) and want to use it with Thunderbird.

Please, think about that! NOT EVERYONE IS USING GMAIL OR FACEBOOK!
(In reply to Vivian from comment #17)

> Why the lastest nightly build of Thunderbird doesn't support other XMPP
> servers than Google?

See bug 735215 for that.
(Reporter)

Comment 19

6 years ago
Bug #714733 (IM in Thunderbird) would be partially solved (for the XMPP part) if this bug was, but not the opposite. They're absolutely not duplicates of each other (and this bug is certainly not a duplicate of #714733 as it is 6 years older).

The feature I'm requesting here is that XMPP can be used in a similar way to SMTP: for normal, email-like messaging (subject, body, etc.). On top of that, nice features that IM brings, such as presence and instant chat, could be brought as well but with very tight integration in mind: for example, a small icon wherever a contact is mentionned (From, To, address book, etc.) indicating if the contact is online. Another nice example would be a quick chat option.

What was developed is probably nice, but for the moment it has little to do with this feature request: it's a separate tab, mimicking what tons of IM clients already do, and it tries to do it in a generic way in order to be used with other protocols, but for the same reason it prevents itself from using most features of XMPP.

I'm not familiar with Mozilla's bug tracking workflow, but it seems sensible to me to reopen the bug.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 20

5 years ago
Hello all. I would add more informations to the previous message from David Ammouial. It's right to say that since Thunderbird get the support of Jabber/XMPP for instant messaging, a big step has been done. XMPP is not only able to chat but also to realize real email-like communications.

Have a look on the XEP-0033: Extended Stanza Addressing http://xmpp.org/extensions/xep-0033.html

Implement this in Thunderbird would allow people to send "slow messages" over XMPP exactly like mails. I invite you to read this analysis of the situation http://translate.google.com/translate?hl=fr&sl=fr&tl=en&u=http%3A%2F%2Fwww.goffi.org%2Fpost%2F2011%2F01%2F18%2FRecevez-et-envoyez-vos-messages-XMPP%2FJabber-avec-votre-lecteur-de-courriel-gr%25C3%25A2ce-%25C3%25A0-Salut-%25C3%25A0-Toi-!%23&sandbox=1 (original in French).

Salut à Toi is a french software that implements XMPP to bring most of the other features that are not well known. This software implement in particular the XEP-0033 as you can see here http://translate.google.fr/translate?hl=fr&sl=fr&tl=en&u=http%3A%2F%2Flinuxfr.org%2Fnews%2Fsalut-a-toi-0-4-0-toujours-en-chemin%23messagerie

I guess there is some English analysis on the Web but I'm french and it's difficult for me to find them. Please, if you read my message, try to find more resources and post them to give more informations about this.
Flags: needinfo?

Updated

5 years ago
Flags: needinfo?
You need to log in before you can comment on or make changes to this bug.