Closed Bug 38586 Opened 20 years ago Closed 20 years ago

leaking scrollbar stylesheet in viewer

Categories

(Core Graveyard :: Viewer App, defect, P3)

x86
Linux
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: dbaron, Assigned: hyatt)

References

Details

(Keywords: memory-leak)

The scrollbar stylesheet in the Chrome Registry is currently being leaked in
viewer.  This makes viewer somewhat less useful as a leak testing tool since it
throws in a bunch of extra leaks.  It's being leaked because mScrollbarSheet is
being assigned into (in ConvertChromeURL) within a call to a getter that assigns
into it (in GetBackstopSheets):

Object 4 held by 0x08337FDC is 1 out of balance.

Put into nsCOMPtr at:
nsGetterAddRefs<nsICSSStyleSheet>::~nsGetterAddRefs(void)+0x00000063
nsChromeRegistry::ConvertChromeURL(nsIURI *)+0x0000030C
nsChromeProtocolHandler::NewChannel(nsIURI *, nsIChannel **)+0x00000445
nsIOService::NewChannelFromURI(nsIURI *, nsIChannel **)+0x000001A4
NS_OpenURI(nsIChannel **, nsIURI *, nsIIOService *, nsILoadGroup *,
nsIInterfaceRequestor *, unsigned int, unsigned int, unsigned int)+0x00000083
NS_OpenURI(nsIInputStream **, nsIURI *, nsIIOService *, nsILoadGroup *,
nsIInterfaceRequestor *, unsigned int, unsigned int, unsigned int)+0x00000064
CSSLoaderImpl::LoadAgentSheet(nsIURI *, nsICSSStyleSheet *&, int &,
nsICSSLoaderObserver *)+0x0000006E
nsChromeRegistry::LoadStyleSheet(nsICSSStyleSheet **, nsCString const
&)+0x0000017B
nsChromeRegistry::GetBackstopSheets(nsISupportsArray **)+0x00000072
DocumentViewerImpl::CreateStyleSet(nsIDocument *, nsIStyleSet **)+0x00000227
DocumentViewerImpl::Init(nsIWidget *, nsIDeviceContext *, nsRect const
&)+0x00000572
nsDocShell::SetupNewViewer(nsIContentViewer *)+0x00000F2A
nsWebShell::SetupNewViewer(nsIContentViewer *)+0x00000022
nsDocShell::CreateContentViewer(char const *, nsIChannel *, nsIStreamListener
**)+0x000003A6
nsDSURIContentListener::DoContent(char const *, int, char const *, nsIChannel *,
nsIStreamListener **, int *)+0x000000E6
nsDocumentOpenInfo::DispatchContent(nsIChannel *, nsISupports *)+0x00000645
nsDocumentOpenInfo::OnStartRequest(nsIChannel *, nsISupports *)+0x0000002D
nsStreamIOChannel::OnStartRequest(nsIChannel *, nsISupports *)+0x0000007B
nsOnStartRequestEvent::HandleEvent(void)+0x00000100
nsStreamListenerEvent::HandlePLEvent(PLEvent *)+0x0000005F
PL_HandleEvent+0x00000056
PL_ProcessPendingEvents+0x00000110
nsEventQueueImpl::ProcessPendingEvents(void)+0x00000070
nsAppShell::SetDispatchListener(nsDispatchListener *)+0x0000003C
keysym2ucs+0x0000015F
g_io_add_watch+0x000000AA
g_get_current_time+0x00000136
g_get_current_time+0x000006F1
g_main_run+0x00000081
gtk_main+0x000000B9
nsAppShell::Run(void)+0x00000067
UNKNOWN 0x08079B1E
UNKNOWN 0x08079DDD
__libc_start_main+0x000000EB
*** Bug 39638 has been marked as a duplicate of this bug. ***
...
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Where is the patch?
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.