Firefox failed to restore Rich Text Editing content and can't input anything into it

RESOLVED DUPLICATE of bug 389274

Status

()

Firefox
Session Restore
RESOLVED DUPLICATE of bug 389274
11 years ago
10 years ago

People

(Reporter: Ginn Chen, Unassigned)

Tracking

({regression})

Trunk
Firefox 3 beta2
regression
Points:
---
Bug Flags:
blocking-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
Steps
1) Start Firefox in terminal
2) Load http://www.mozilla.org/editor/midasdemo/ , input something into it
3) Press Ctrl+C in terminal to kill firefox
3) Restart Firefox, and select Restore Session
4) The text you inputed is not restored, and you can't input anything into it.
Refresh doesn't help. You have to close the tab and open another one.

I got this in Error Console:
JavaScript error: , line 0: uncaught exception: Permission denied to set property HTMLDocument.designMode

Firefox 2.0.0.4 doesn't have this issue.
(Reporter)

Comment 1

11 years ago
Another test case:
I guess it's a similar cause.

1) Load any webpage in one tab.
2) Load http://www.mozilla.org/editor/midasdemo/ in the same tab , input something into it.
3) Press "Back" button
4) Press "Forward" button
5) You  get saved text in edit area, but you can't edit it now.
6) Press "Reload" button, edit area is empty, and you can input now.

Expected result:
5) You get saved text in edit area, and you can edit it.

Updated

11 years ago
Flags: blocking-firefox3?

Updated

11 years ago
Flags: blocking-firefox3? → blocking-firefox3+

Updated

11 years ago
Keywords: qawanted
Target Milestone: --- → Firefox 3 M8

Comment 2

11 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007072304 Minefield/3.0a7pre

So... I filed bug 389274 for the regression I was seeing on branch , thinking it might be a different bug. It turns out it's actually caused by the same patch (bug 332182). I'm going to mark this dependent on bug 389274 for now, as I've CC'd the calvary on that one, and expect a fix to show up there.

FWIW, I think the issue you mention in comment 1 is bug 304994 (see bug 382235, which was duped to it).
Depends on: 389274
Keywords: qawanted
OS: Linux → All
Hardware: PC → All

Updated

11 years ago
Target Milestone: Firefox 3 M8 → Firefox 3 M9
moving out bugs that don't need to block b1
Target Milestone: Firefox 3 M9 → Firefox 3 M10
Isn't this just a duplicate of bug 389274?
Looks like it, marking as such since this seems to be fixed now.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 389274
You need to log in before you can comment on or make changes to this bug.