Last Comment Bug 386172 - Thunderbird crashes when Lightning 0.5 and BirdieSync 1.5.4.3 are installed
: Thunderbird crashes when Lightning 0.5 and BirdieSync 1.5.4.3 are installed
Status: VERIFIED INVALID
FIX: update to BirdieSync 1.5.5.0
:
Product: Calendar
Classification: Client Software
Component: Lightning Only (show other bugs)
: unspecified
: x86 Windows XP
: -- critical (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-28 05:23 PDT by Erik Guilfoyle
Modified: 2008-02-21 01:41 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Erik Guilfoyle 2007-06-28 05:23:54 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: TB-20070604

*Note that this error may be due to BirdieSync extension and I am attempting to verify whether or not this is true.

Installing or upgrading Lightning 0.5 crashes the Thunderbird 2.0.0.4 with a Windows error as Thunderbird attempts to load. This occurs after updating Lightning or after installing Lightning.

Currently the only work-around to such a crash is to load Thunderbird in safe mode and either uninstall or disable Lightning.

Reproducible: Always

Steps to Reproduce:
1. Install Lightning 0.5
2. Start Thunderbird 2.0
3. Crash
Actual Results:  
Windows crash error and Thunderbird error reporting pops up.

Expected Results:  
Should have loaded without a crash.

I do have one other addon installed and I have not been able to test if it is the cause of the crashes. I have installed BirdieSync extension and I do not know if this is the cause of the crashes just yet. I also don't know if the crash is limited to a single extension.
I will confirm if the BirdieSync extension is the cause in one day. However I believe that this bug should be tested in an environment with other extensions as a precaution.
Comment 1 Daniel Boelzle [:dbo] 2007-06-28 06:09:58 PDT
I can't confirm that Lightning 0.5 crashes on Thunderbird 2.0.0.4 (Windows). I suspect it's a BirdieSync incompatibility.
Comment 2 Stefan Sitter 2007-06-28 06:28:33 PDT
(In reply to comment #0)
> Windows crash error and Thunderbird error reporting pops up.

Please provide the Talkback Incidents ID for the sent crash report.
Comment 3 Stefan Sitter 2007-06-28 06:34:12 PDT
If BirdieSync accesses the calendar stuff somehow this might be a similar issue as in Bug 384850. The Funambol extension was updated for Lightning 0.5, so maybe the BirdieSync extension need an update too.
Comment 4 Stefan Sitter 2007-06-28 06:37:39 PDT
What BirdieSync version do you use?

According to [http://birdiesync.com/forum/viewtopic.php?t=348] BirdieSync 1.5.4.5 was released some days ago and fixes "Thunderbird could crash if Lightning was not compatible with BirdieSync".
Comment 5 Erik Guilfoyle 2007-06-28 06:44:42 PDT
The birdiesync developer may already know as he just released a new version today. I will test this new version and report back in about 10 hours (return home after work).

I am going to close this error report. According to the birdiesync forum:

"Yep. It will crash if you have both Lightning 0.5 and BirdieSync 1.5.4.3 going. You need to disable one or the other in No Extension mode."

"BirdieSync 1.5.5.0 is released and supports Lightning and Sunbird 0.5."

You guys are fast and good. Thanks for all the help and I hope this report helps someone else.
Comment 6 Lasher 2007-07-03 02:38:33 PDT
I have the same prob, better update Birdiesync then.
thanks for the info
Comment 7 Stefan Sitter 2007-07-04 02:55:40 PDT
Simon, I'd like you to add this to the Lightning 0.5 Known Issue page.
Comment 8 Simon Paquet [:sipaq] 2007-07-04 03:12:13 PDT
(In reply to comment #7)
> Simon, I'd like you to add this to the Lightning 0.5 Known Issue page.

Done.

Comment 9 Lasher 2007-07-04 08:25:34 PDT
I upgraded to BirdieSync 1.5.5.0 last night and it works fine now thanks.

Note You need to log in before you can comment on or make changes to this bug.