Closed Bug 386197 Opened 13 years ago Closed 12 years ago

all calendar entries invisible after first navigation

Categories

(Calendar :: Calendar Views, defect, critical)

Lightning 0.5
x86
Windows XP
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: gunther.lenz, Unassigned)

References

Details

(Whiteboard: [0.5 disappearing events])

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.4) Gecko/20070515 FireFox/2.0
Build Identifier: Thunderbird Version 2.0.0.4 (20070604), Lightning 0.5

On startup of TB+Lightning and clicking on a date in the minicalendar the month overview appears and shows no entries.

When clicking on the "weekly view"-icon all entries for this week are shown properly.
As soon as I navigate to another week all entries disappear and also don't come back again.

By clicking on "day-view" the items for the actual day are shown. As soon as I navigate to another day also every item disappears.

After doing this once for day-view and week-view all entries keep invisible. Changing the views doesn't fix it until you restart thunderbird.

From the fast speed of the "empty" redraw I guess lightning thinks there are no entries in the calendars at all.

Sidenote: The items in the ToDo list are displayed properly.



Reproducible: Always

Steps to Reproduce:
1. start thunderbird

2a. click date in minicalendar:
calendar appears in month-view and empty

or

2b. press one of the calendar view icons:
calendar appears in selected view and shows all entries

3. navigate in time by either the arrow icons, week numbers or month names:
calendar is drawn without any entries

4. navigate or switch views:
calendar still doesn't show any entries
Actual Results:  
calendar entries are not drawn anymore

Expected Results:  
calendar entries should be drawn
Severity: normal → critical
Version: unspecified → Lightning 0.5
1) This started when I updated Lightning from 0.3 to 0.5 via Thunderbirds "check for updates" in the addons-dialog
2) I'm using the german version of TB & Lightning
3) I first thought all calendar entries were lost [little heartattack], but it seems they all are still there but invisible
Gunther, what type of calendars do you have?  Is this with CalDav calendars, ICS calendars, local calendars etc?

Thanks for the information.
I have 3 local calendars and 8 ICS calendars.

After a little experimenting I found the following solution:
1) removed all remote calendars
2) subscribed to the remote calendars again

After this all views work as expected.

BTW: Simply reloading the remote calendars did not fix the problem.
I had exactly the same problem. Removing remote calendars and re-subscribing fixed it (although I had to do it twice); reloading did not.

My remote calendar was an ics calendar (it was actually my google calendar processed through GCALdaemon into an ics).
Moreover, even after resubscribing to my remote calendars, the problem recurred after checking email and then clicking a day on the minicalendar (although this time, the events came back if I manually select "Month view", etc.). Icky.
I had the same problem in Sunbird 0.5 release build, with 8 ICS remote calendars. I resubscribed them all and it appears to have fixed the glitch and as above reloading did not fix the problem - required a restart of Sunbird to fix it. 
This reminds me of bug 369885.
Of interest, this problem seems to be much more difficult to get rid of than I'd thought because sometimes (I can't figure out how this is controlled) clicking the "close" control on the thunderbird Windows XP window doesn't actually close it, but leaves it around (it reappears in the tray when new mail is received). 

If I actually terminate the process and restart, I get my calendars back (after that initial re-subscribe, of course). I am not using MinimizeToTray or any similar add-on.
Yes, hopefully this will help tomorrows big test day for this bug.

At home (I don't have this problem at work, oddly, with the same Lightning setup), start Thunderbird, enter my master password, there's my calendar (remote ICS served by GCALdaemon) in Lightning, good. Can see events, etc. On the back end, GCALdaemon's logs show a successful GET of the calendar from google.

Next, delete an event. The calendar vanishes! GCALdaemon log says:
2007-07-09 20:26:58 | DEBUG | HTTPListener   | Processing PUT method...
2007-07-09 20:26:58 | DEBUG | HTTPListener   | Password required!
2007-07-09 20:26:58 | DEBUG | HTTPListener   | Response processed with status code 401.

So an attempt to PUT the changed calendar to google failed, and now Lightning won't show me anything.

Attempt to close Thunderbird and restart, calendar's not back. Close thunderbird again.

Run Taskmgr - Thunderbird is still a running process. Kill it. Start thunderbird again. Calendar is back as at the beginning of this cycle.

Delete the calendar and resubscribe to it. Delete an event. Same thing.

Delete the calendar and *also* delete the stored password for the calendar's url under the master password. Resubscribe to the calendar. Delete an event. *Now* it works, and GCALdaemon logs:

2007-07-09 20:31:15 | DEBUG | HTTPListener   | Processing PUT method...
2007-07-09 20:31:15 | DEBUG | HTTPListener   | Calendar changed at /calendar/ica
l/alansz%40gmail.com/private-c9aeb894dd74942911f86c7c30348712/basic.ics.
2007-07-09 20:31:16 | DEBUG | HTTPListener   | Response processed with status co
de 201.

At this point, things seem ok.

Summary/interpretation: The bug is actually in the stored passwords for remote calendars. Although they appear correct after the 0.3.1 to 0.5 upgrade, they are not transmitted correctly until the stored password entry - not just the remote calendar subscription - is actually removed and recreated. When they are not transmitted correctly, Lightning behaves strangely, showing a blank calendar without providing a diagnostic message to indicate the problem.

That's the best I've done so far. Somebody post this to the test wiki for me tomorrow if I forget. :)
See also 380291 and 380292, which may be related to this one. Although I thought that switching the stored password fixed everything, Thunderbird still did not terminate properly on "exit" later that day at least once (although there were no PUTs logged by gcaldaemon in the period). This may be a separate bug or it may be that the calendar issues are crashing something that the rest of the process is waiting on before it exits or something. 
Whiteboard: [0.5 disappearing events]
We have seen in other bug reports, that this might be due to the use of a proxy on the network. Gunther, are you using a proxy on your network?
(In reply to comment #11)

No, there were no proxies in use.
The calendar server and the TB client reside in the same local network.
I think, by the way, that the status of this bug should no longer be UNCONFIRMED, and it should be an 0.7 blocker.
Yesterday the problem appeared again.
One of the calendars was unreachable and suddenly all calendars were invisible - including the local ones.

Also there was the effect, that in every view (day, week, month) the available calendar entries were drawn initially and then everything disappeared as soon as I started navigating in time.
I'm not sure this is related to this bug but it could help

The disappearing event cam back today. I had one week without even that disappear.

I have 16 .ics calendars on icalx.com. On SB start, the selected calendars appear one by one and disappear when the next is loaded. Once the process is finish only one calendar remain (not always the same) and the others disappear. 

On the events list, events of some calendar still their without appearing on the main window. At this point if i reaload remote calendars all calendars disappear of the main view but not always from the event list.

If i close Sb, and reopen it noting change. If i close it again and take a look in the task manager sunbird.exe process still their (related to bug 378578 ?).  If i force quit sunbird.exe and reopen it calendar will load again (with or without event disappearing).

It's like their is a problem with reloading calendar but since bug 323952 is not corrected i know no way to be award of calendars loading. Even if i knew it i have no way to aboard the download and restart it lather.

No errors in the error consol

Repeatability:
-Event disappear (more i make change and reload calendars more it chance to hapen)
- sunbird.exe process stay in the task manager always of Events disappeared.

OS: Windows Xp sp 2
SunBird rv:1.8.1.7pre (2007/08/09)
Ics calendar: icalx.com (privat)
Disappearing/reappearing calendars:

I'm out of office today, so some of my ics-calendars cannot be reached.

I started TB, switched to Month View and again no calendar entries were shown.

But then, without any interaction, some minutes later the entries of the local calendars appeared again. I never had this effect seen before.
(In reply to comment #9)
hmm, I can't reproduce Alan's problem writing on google cal via gcaldaemon, even if using a stored password.
Still happens to me, with latest nightly of 0.7. Add an entry in lightning, change weeks, calendar entries all vanish, and thunderbird won't properly shut down. I hope we'll get a fix for this sometime in 0.7 -- it seems like it's pretty clear where and what the bug is (failure to correctly handle the protocol where a PUT needs authorization), and that it's a serious regression (this all worked right in 0.31).
This is evidently a duplicate of bug 387559, because the 12 Sep 2007 patch there fixed this for me! Great job!
So far it seems so - I can now upgrade from 3.1! Thanks for the team who worked on this, much appreciated. 
Gunther, bug 393387 was fixed a few days ago and might help with the issue reported here too. I'd like you to retest with a Sunbird or Lightning 0.7pre (20070918) or newer build if your issue still exists.
The problem seems solved for me.

Gunther, does the issue still exists using Lightning 0.7 Release Candidate 1?
<http://releases.mozilla.org/pub/mozilla.org/calendar/lightning/releases/0.7rc1/>
(In reply to comment #23)

Tried the version 0.7rc1 from Oct. 2nd and so far it works great. :)

Will continue testing and report any further problems.
Resolving WORKSFORME per Comment #24.
Please reopen the bug or file a new one if you experience further issues.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Depends on: 393387
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.