Space character is the wrong width in Courier, other bitmap fonts?

RESOLVED FIXED

Status

()

Core
Graphics
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: Justin Kerk, Assigned: Stuart Parmenter)

Tracking

({regression})

Trunk
x86
Windows XP
regression
Points:
---
Bug Flags:
blocking1.9 +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
After the re-fix of bug 324706, bitmap fonts are working on Windows again, but space characters don't seem to be rendered with the correct width in e.g. the Courier sample at the top of attachment 209619 [details]. If you try selecting character cells on different lines you can see that the monospace-ness is broken.

My guess is that some other font is rendering the spaces because the hack-fix for 324706 only covers characters 0x21-0xff (space is 0x20), but I'm no Mozilla developer.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a6pre) Gecko/20070628 Minefield/3.0a6pre ID:2007062805
(Reporter)

Comment 1

11 years ago
Created attachment 270391 [details]
Screenshot of character cells not lining up
Flags: blocking1.9?
Keywords: regression

Comment 2

11 years ago
Bug 347646 might be related.
Assignee: nobody → pavlov
Flags: blocking1.9? → blocking1.9+
(Assignee)

Comment 3

11 years ago
Created attachment 276152 [details] [diff] [review]
fix
Attachment #276152 - Flags: review?(vladimir)
(Assignee)

Comment 4

11 years ago
Comment on attachment 276152 [details] [diff] [review]
fix

whoops, ignore the #define at the top.
(Assignee)

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.