Message pane context menus show mailnews items in browser areas

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
P3
normal
RESOLVED WORKSFORME
18 years ago
14 years ago

People

(Reporter: scottputterman, Assigned: scottputterman)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

18 years ago
The message pane context menus shouldn't show mailnews menuitems like reply, 
forward, etc when right clicking on browser related items such as images and 
links.

Updated

18 years ago
QA Contact: lchiang → nbaca
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → M17

Comment 1

18 years ago
When verifying, use the Mail Menus Spec and go to the Message Body section for 
specifics. 
1. Link selected
2. Image/Link selected
3. Image/Not Link selected 

Comment 2

18 years ago
I assume, those items should be on the, too (just like 4.x).
OS: Windows NT → All
Hardware: PC → All

Comment 3

18 years ago
em, "on the top".

Comment 4

18 years ago
I'm not sure what is meant by "on the top". According to the spec here is what 
will appear in the context menu when a Link, Image/Link or Image/No Link is 
selected. Does this answer your question?

1. Link selected
Open Link in New Window
Open Link in Composer 
--------------------
Copy Link Location 
--------------------
Save Link As... 
Add Link To Bookmarks 
--------------------
Link Properties

2. Image/Link selected
Open Link in New Window
Open Link in Composer 
--------------
View Image <name> 
--------------
Copy Link Location 
Copy Image --- Ctrl+C 
Copy Image Location 
---------------
Save Link As...
Save Image As...
Add Link To Bookmarks 
----------------
Image Properties
Link Properties 

3. Image, not link
View Image <name> 
Copy Image --- Ctrl+C 
Copy Image Location 
-------------
Save Image As... 
-------------
Image Properties 

Comment 5

18 years ago
nbaca, yes, that is what i meant (i have no access to google :( ). I *very*
often do "Open Link in New Window" and it should be the first item (like the
spec says).

Comment 6

18 years ago
> google

nonsense, gooey, of course
(Assignee)

Comment 7

18 years ago
moving to future milestone.
Target Milestone: M17 → Future

Comment 8

18 years ago
nominating for nsbeta2. "Open in new window" is a *very* frequent action (I do
that for every second mail), and should be accessible very fast. (On Unix, you
might be able to middle-click, but not everyone can do that.)
Keywords: 4xp, nsbeta2

Comment 9

18 years ago
> "Open in new window"

"Open Link in New Window", that is.
(Assignee)

Comment 10

18 years ago
Yes, but the summary of the bug and as it was filed is "Message pane context
menus show mailnews items in browser areas" regardless of what the discussion
became, I don't plan to fix the original bug any time soon.

Updated

18 years ago
Keywords: 4xp, nsbeta2

Comment 11

18 years ago
Filed bug 44223 about "Open Link in New Window" moving to top. Removing nsbeta2
and 4xp nomination for that reason.

Comment 12

17 years ago
*** Bug 91505 has been marked as a duplicate of this bug. ***

Comment 13

16 years ago
I changed QA contact from nbaca to olgam.
QA Contact: nbaca → olgam

Updated

16 years ago
Blocks: 158011

Comment 14

16 years ago
Putterman: I think this bug is fixed. 
(original description and everything else people were suggesting)
Resolve?

Comment 15

16 years ago
No reaction etc., but this was fixed somehow during the last two or three years
(see summary, description and comment #10).
->WFM
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.