using vertical scrollbar changes horizontal scroll position with overflow-x: hidden and overflow-y: scroll

RESOLVED FIXED in mozilla8

Status

()

Core
Layout
RESOLVED FIXED
10 years ago
6 years ago

People

(Reporter: Mitchell Skinner, Assigned: roc)

Tracking

({testcase})

unspecified
mozilla8
x86
All
testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 -, status2.0 wanted)

Details

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4

On a div with overflow-x: hidden and overflow-y: scroll, scrolling using the (vertical) scrollbar changes the horizontal scroll position.

Interestingly, scrolling with the mouse wheel doesn't seem to affect the horizontal scroll position

Reproducible: Always

Steps to Reproduce:
1. View the attached test case
2. Try to scroll with the scroll bar
Actual Results:  
Horizontal scroll position changes

Expected Results:  
Horizontal scroll position should stay the same
(Reporter)

Comment 1

10 years ago
Created attachment 270433 [details]
test case
Component: General → Layout
Product: Firefox → Core
QA Contact: general → layout

Comment 2

10 years ago
I can reproduce the problem with the latest trunk builds on OS X.
(I thought there was already a bug filed on this, but can't find it.)

Comment 3

10 years ago
I can't find any other reports of this either
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase
OS: Linux → All

Comment 4

7 years ago
this bug is still unresolved in Fx 3.6.

Some form of acknowledgement from Mozilla devs would be much appreciated.

thank you.

Comment 5

7 years ago
Mystix, seem like Mozilla dev 'semi' acknowledge this:

https://bugzilla.mozilla.org/show_bug.cgi?id=571201

Worried to see this bug have been pending for so many years!
Duplicate of this bug: 571201
This is probably really easy to fix
Assignee: nobody → roc
blocking2.0: --- → ?
Duplicate of this bug: 577760
blocking2.0: ? → -
status2.0: --- → wanted

Comment 9

6 years ago
Bug still not fixed and more similar reports are filled.

https://bugzilla.mozilla.org/show_bug.cgi?id=623937

https://bugzilla.mozilla.org/show_bug.cgi?id=436650

Comment 10

6 years ago
(In reply to comment #7)
> This is probably really easy to fix

Any news?
Created attachment 542375 [details] [diff] [review]
fix

I don't know of a good way to test this. To hit this path, we have to synthesize events on the scrollbar or else set the attribute of an anonymous scrollbar directly, and I don't know how to do either of those reliably.
Attachment #542375 - Flags: review?(dbaron)
Comment on attachment 542375 [details] [diff] [review]
fix

r=dbaron
Attachment #542375 - Flags: review?(dbaron) → review+
Whiteboard: [needs landing]
Blocks: 436650
http://hg.mozilla.org/integration/mozilla-inbound/rev/7c0489e8acaf
Whiteboard: [needs landing] → [inbound]
I'm not sure that bug 623937 is the same as this bug. We'll see if it's fixed by my patch.
Blocks: 343254
https://hg.mozilla.org/mozilla-central/rev/7c0489e8acaf
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Whiteboard: [inbound]
Target Milestone: --- → mozilla8

Updated

6 years ago
Duplicate of this bug: 343254
You need to log in before you can comment on or make changes to this bug.