Add a new provider, based on libmapi

RESOLVED DUPLICATE of bug 134763

Status

Calendar
General
--
enhancement
RESOLVED DUPLICATE of bug 134763
11 years ago
a year ago

People

(Reporter: Jochen Wiedmann, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a5) Gecko/20070606 GranParadiso/3.0a5
Build Identifier: 

The OpenChange project offers a library called "libmapi", which allows to connect to an MS Exchange server via its native protocol. Integration of this library into Sunbird/Lightning could boost up the use in corporate environments.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

11 years ago
Jochen, thanks for the pointer. That sounds quite interesting, but we cannot use the OpenChange code, because they are using the GPL exclusively.

All Mozilla code is tri-licensed under the MPL/GPL/LGPL. Therefore OpenChange would also have to tri-license its code to enable us to use their code.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

11 years ago
I see the problem. However, may I point you to comment 32 in bug 386521 ? The author is no other than the project head. So it seems worth asking. Apart from that, may be the project will switch to GPL v3 in the future, which is much more friendly in that area.
(Reporter)

Comment 3

11 years ago
Sorry, wrong bug number: I was referring to bug 167102

Comment 4

11 years ago
Thanks for the information, Jochen. I'll try to contact Julien. Looking at the OpenChange website though, it seems to me that this library is Linux-only.

That would be another drawback, since we're building a cross-platform client on Windows, Mac and Linux. We also have working builds for Solaris and OS/2.

Comment 5

11 years ago
An Exchange provider based on MAPI (and not on Exchange WebDAV) would of course boost Mozilla Calendar; I agree that's what most likely corporate environments are looking for: alternatives to Outlook without the need to exchange ;) their backend. Thanks for the pointer, Jochen!
Regarding the license: Wouldn't it be sufficient if such a provider is hosted outside of mozilla? However, this would complicate releases / alignment with the core code.

Comment 6

10 years ago
Isn't bug 134763 sufficient to track an Exchange provider (regardless of how it works internally); should we set this bug to duplicate?

Comment 7

7 years ago
I think this is a duplicate.

By now there is even an exchange provider -- although not based on libmapi.
See http://gitorious.org/lightning-exchange-provider for more information.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 134763
You need to log in before you can comment on or make changes to this bug.