Last Comment Bug 167102 - Migrate Outlook (Express) Calendar Data
: Migrate Outlook (Express) Calendar Data
Status: RESOLVED DUPLICATE of bug 549225
:
Product: Calendar
Classification: Client Software
Component: Import and Export (show other bugs)
: unspecified
: All All
: -- enhancement with 24 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
http://outport.sourceforge.net/
: 194392 (view as bug list)
Depends on: 173562
Blocks: cal-importing
  Show dependency treegraph
 
Reported: 2002-09-06 08:30 PDT by Tobias
Modified: 2010-02-28 11:45 PST (History)
41 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Tobias 2002-09-06 08:30:58 PDT
Hello, I would love to import my Outlook calendars into the Mozilla Calendar but
don't know how and missing a Import feature in Mozilla. Maybe someone could do
this (sorry, I am just a stupid user and not a programmer...)

Thanks,
Tobias

BTW: I can't import the holidays, they will just not appear in the calendar
Comment 1 ajbu 2002-09-07 03:35:59 PDT
Hi, Import /Export is in the Calendar Tools menu. Outlook can export to ics 
files.

>BTW: I can't import the holidays, they will just not appear in the calendar
Please file a bug for that, with the following information:
- Exact steps you did to reproduce
- Calendar/Mozilla version (see about/calendar menu)
- Open the Tools/'Web Development' / 'JavaScript console' menu and copy any 
javascript errors you see to the bug report.
Comment 2 Mike Potter 2002-09-13 06:14:47 PDT
http://www.cyberus.ca/~phoenix/outport/
Maybe of something of interest as well.
Confirming this bug, maybe we can take some of that code and put it directly
into the calendar for windows users to access their outlook events directly.
Comment 3 Tobias 2002-10-20 04:57:35 PDT
nothing happened for a while here.... if just someone could tell me what Outlook
version do I need to export to ics files? I am using Outlook2000 with now
different ServiceReleases and I never have seen such export features.....
Does someone know if there are some projects for Outlook to publish the Outlook
Calendar also to a remote web site?
Comment 4 Mike K 2002-10-28 14:10:41 PST
I have the same problem. It appears that Outlook 2000 does not support ICS as an
export format, but apparently Outlook 2002 does. See Microsoft KnowledgeBase
Articles #Q202276 (Outlook 2000 supported formats included in body) and #Q287089
(Outlook 2002). Site is http://www.microsoft.com/support, click on "Search the
Knowledgebase" and enter the article #. Note that the KnowledgeBase page does
not render well in 1.2A (but does very nicely in IE...surprise)

I have not tried this, but apparently Outlook 2000 will support saving
individual appointments as vCalendar (.vcs files)(#Q197025). I'm not sure if
there's a way to bring those into Mozilla Calendar. The Mozilla Import function
doesn't seem to recognize that file type.
Comment 5 scottymomo 2002-11-01 18:49:20 PST
Palm Desktop also exports as vCal (.vcs) files, would love to move off of it to Moz.
Comment 6 Mike Potter 2003-03-21 06:45:25 PST
*** Bug 194392 has been marked as a duplicate of this bug. ***
Comment 7 Justin Bennett 2003-05-20 12:29:44 PDT
IN the previous version of Calendar you used to be able to import a .csv file
from an Outlook Export... How come we can't anymore?
Comment 8 Mike Potter 2003-08-06 07:10:24 PDT
New contact from mikep@oeone.com to mostafah@oeone.com
Filter on string OttawaMBA to get rid of these messages. 
Sorry for the spam.
Comment 9 franCk 2003-08-06 07:28:51 PDT
To set the record straight: Outlook 2002 can not export vcs or ics files it can
only *import* them (as far as I can tell, of course)
<spam>if we want Calendar to be brodaly accepted I fear 'we' will have to find a
way to recognize the format from Outlook</span>
Comment 10 Casey A. Peel 2004-01-17 20:49:21 PST
Added dependency on bug 173562 (need to import Outlook CSV file) for tracking.
Comment 11 Ken Kauffman 2004-03-22 21:19:45 PST
This worked for me.  I suggest you guys work with the Outpost people on
providing this as a utility reference.

http://outport.sourceforge.net/

Regards
Ken Kauffman
Comment 12 Ken Kauffman 2004-03-22 21:22:29 PST
I also did not mention that the export feature of Outlook does not allow for
recurring event exports, except as "static" entries within a time period, so
Outpost was my only option as it allows more export formats. (PS: don't know why
I *signed* my bug comment before - doh!)
Comment 13 Stephen Burnett 2004-08-31 18:43:49 PDT
There is a way that works rather neatly with this Import/Export problem with
Microsoft Outlook 2000 (and forward, I believe).

The program Outlook2VCal, from the KDE.org website allows Outlook 2000 and
forward Calendar events to be Exported to a single file as type vCal.  This
single file can then be Imported into Mozilla Calendar correctly.  It simply
works, and that is all we need.

The program for Outlook2VCal is available at: 
http://korganizer.kde.org/learning/importdata.html for free.  Download it and
give it a try -- you should be "golden".

Hope this helps!

Thank you.

Stephen
Comment 14 Michael 2004-11-06 12:03:34 PST
FYI, The program Outlook2VCal from the KDE.org is not perfect... it has a few
issues, but it generally works.  

Funny enough, the generated ics files do NOT import back into Outlook!  

Also another note, Outlook can generate .ics files, but only one event at a
time.  Use the Save As after you highligth an event.  This is usefull for
verifying all information is transfered from Outlook into a ics file from
Outlook2vcal.

FYI, I have generated a macro for exporting Microsoft Excel spreadsheet
calanders (I have a few customers that use Excel :-( ).  It is simple, and does
not currently work with recurrening events,  but I did not need to do those.   
If anyone wants it, just ask.. I will gladly turn over the macro code.
Comment 15 cliff 2004-11-18 09:30:39 PST
The Calendar imports Outlook .csv file as "events" not "tasks".
Comment 16 gekacheka 2004-11-18 17:34:09 PST
Bug 173562 is for importing Outlook CSV files.
Please go there and attach an example file of tasks, all the examples there are
events.
Comment 17 Stephen Burnett 2004-11-18 18:23:41 PST
I hate to sound like a broken record, but Outlook2VCal does work for Export of
Outlook data to a vCal file and subsequent Import of that vCal data file into
Mozilla Calendar.

It may not be perfect in terms of re-export/importing the data back from Mozilla
Calendar to Outlook, but getting it over here into Mozilla Calendar is really
what the original problem was.  That makes Outlook2VCal a workaround, but a good
one.

I have been using it for about a year and this method (using vCal Exports from
Outlook, then Importing those into Mozilla Calendar) and it has not lost any
significant data from any of the Export/Import cycles.  Once again, if you want
the link to Outlook2VCal it is located at
http://korganizer.kde.org/learning/importdata.html.

Outport, on the other hand, has tended to make a real mess of the Export files
for me, so I am not using it regularly; but I am keeping up a testing pattern
periodically to see if it improves for me.

I have been monitoring this bug for significant time, and will continue to do
so.  IMHO, it would help a great deal if the development team would implement at
least one of the known solutions (even a cleaned-up workaround like Outlook2VCal).

Thanks, everyone.

Stephen Burnett
Comment 18 George Hyman 2004-11-19 11:50:01 PST
Why just import?  Why not integrate with outlook like Evolution does on linux?
see: http://gnome.org/projects/evolution/  
Comment 19 R.C.H. 2004-11-30 11:06:08 PST
Perhaps related, perhaps unrelated issue. Let me know if you want to keep this
as a current bug or open a new one.

This bug discusses Outlook calendar events set up on current user computers.
However, I don't have my own Outlook calendar. Instead, I get emails with
Outlook users with calendar events in VCalendar format. I can cut and paste the
email text into a new .vcs file and I can successfully import it into Sunbird.
However, that's awfully inconvinient.

I could not find an easy feature to import VCalendar events which I receive by
email into calendar. I use Thunderbird for email and Sunbird for calendar
(usually latest versions).
Comment 20 Steve Chapel 2004-11-30 11:42:46 PST
I think recognizing events in emails would be bug 59630 or bug 134763?
Comment 21 gekacheka 2004-11-30 20:11:53 PST
(In reply to comment #18)
> Why just import?  Why not integrate with outlook like Evolution does on linux?
> see: http://gnome.org/projects/evolution/  

Not sure what you mean here... Do you mean their purchasable add-on to operate
with MS Exchange via its "Outlook Web Access" feature?
http://gnome.org/projects/evolution/doc/c2925.html

If so, is the MS Exchange "Outlook Web Access" a documented API?
Comment 22 石庭豐 (Seak, Teng-Fong) 2004-12-16 07:17:12 PST
Maybe a little off-topic:
From Outlook (2k, XP or 2k3), the exported CSV (comma-separated format, not VCS)
is localised.  For instance, my Outlook is in French.  So the first line in the
CSV file is
"Objet","Début","Début","Fin","Fin",......
instead of
"Subject","Begin","Begin","End","End",......

So I need to make a match between field names.  Very annoying.
Comment 23 gekacheka 2004-12-16 15:46:42 PST
(In reply to comment #22)
> the first line in the CSV file is
> "Objet","D�but","D�but","Fin","Fin",......
> instead of
> "Subject","Begin","Begin","End","End",......

Are you using Calendar with the fr-FR UI Locale?

(It should match those column names in the fr-FR locale.  If it doesn't, there
may be a character encoding issue.)

Please post an example file as an attachment to Bug 173562.  

Please post any followups on this topic to Bug 173562.
Comment 24 urho.konttori 2005-04-26 02:30:18 PDT
if you   go to ximian site you  can see that ximian connector is under GNU
lisence these days. It would be great if you could integrate it to calendar

https://store.ximian.com/xproddetail.php?sku=XCN14-DL-U01
Comment 25 Andrew Loss 2005-05-09 14:07:20 PDT
this would realy help because all my stuff is in outlook

thanks
Comment 26 Aleksandar Milivojevic 2005-07-21 08:59:00 PDT
While it would be nice to have importing using files work nice and smooth, I
beleive Sunbird should also have support for SyncML protocol.  Synchronizing
calendars by importing/exporting using files is a tedious job.  SyncML is an
emerging standard.  There's SyncML plugin for Outlook, and also most newer
mobile devices have support for it (mobile phones, PalmOS devices, and so on).

The calendar that just sits on my PC isn't much usefull.  The calendar that I
can sync between my desktop PC, notebook, mobile phone, Palm Pilot, and/or my
webmail application (for all of which SynML support is either readily available
or will be soon) from anywhere in the world where I could get Internet
connection is something completely different.
Comment 27 Dr. David Alan Gilbert 2005-10-30 12:19:36 PST
MAPI perhaps?
Would it be possible for mozilla calendar to actually use MAPI to sync to an outlook on the same machine?  It strikes me that there are various commercial outlook plugin attempts (and the start of some free ones), but if Mozilla Calendar is going to gain interroperability with many of the free calendar servers out there then using it to do the syncing with Outlook directly might be the solution to getting existing (immovable) outlook users to be able to access a free server
that all their opensource using colleagues are using.
Comment 28 Tobias B. Besemer [:BesTo] (QA) 2005-12-03 08:21:43 PST
Can somebody change Hardware & OS to "all"?
Comment 29 Bernie 2006-03-07 12:57:05 PST
When using Thunderbird to obtain my emails from Exchange using IMAP, whew, I get a 'Calendar' folder, which contains an email for each calendar event. Inside the guts of the email appear to be vCalendar formatted data. If this is a common feature of Exchange, this would seem to be a great approach to integrating the Mozilla calendar with Exchange.
Comment 30 Andrew N Dowden 2006-04-11 22:43:14 PDT
This should be linked to Bug 134763 (interact with MS Exchange)

Particularly after Comments 27, and 29.
Comment 31 Matthew (lilmatt) Willis 2006-07-10 07:03:02 PDT
Reassigning all automatically assigned bugs from Mostafa to nobody@m.o

Bugspam filter: TorontoMostafaMove
Comment 32 Julien Kerihuel 2007-05-04 13:18:14 PDT
For people interested in native Exchange support on Linux platforms, OpenChange has a working MAPI library and just added calendar fetch and appointment/meeting support. It is still alpha, but we are already able to:
- create appointment or meeting
- define start/end date
- set the busy status and the label
- define the title and location

Reminders support and stand-alone application should be added to the repository within a couple of days.

If someone is interested in adding MAPI support using libmapi, we would be more than happy to provide the necessary help.

Infos and screenshots available on: http://www.openchange.org
Comment 33 Black Berry 2007-06-29 04:56:36 PDT
Hi,

i'm using plugin Lightning v0.5 with TB v2.0.0.4.
When a MS Outlook user sends me an event, the pluging correctly identify the event calendar and add it to my local calendar but the user doesn't receive back the confirmation of the event.

Another issue, very easy to solve.
When i export my calendar from my symbian phone is exported with a different extension (.vcs) instead of .ics. Renaming the extension to .ics solve the issue. Maybe you can insert in the import function the ability to have lso this extension or whatever.

great work
Berry
Comment 34 Jochen Wiedmann 2007-07-01 13:11:16 PDT
(In reply to comment #32)

> For people interested in native Exchange support on Linux platforms,
> OpenChange has a working MAPI library and just added calendar fetch and
> appointment/meeting support. It is still alpha, but we are already able to:
> - create appointment or meeting
> - define start/end date
> - set the busy status and the label
> - define the title and location

Julien, I am highly interested in such a feature and have therefore submitted Bug 386521

Comment 35 maxer 2008-01-16 14:14:21 PST
curious if anyone knows if you are receiving your yahoo mail in thunderbird and if someone sends you a meeting reqest (calendar event) from outlook - is this calendar event/meeting request importable directly into the sunbird calendar?

your help is appreciated!
Comment 36 David Birnbaum 2008-05-13 20:26:37 PDT
Greetings.

I have been doing a lot of Outlook calendaring using the Stalker Communigate application with the MAPI plugin.  It works great; the only downside is that you have to use Outlook as the client.  I have been watching the recent release of CalDav and hoping that we could start rolling out Thunderbird as a replacement PIM for our clients, relieving them of the need to spend a lot of $$$ on Outlook.

I tried today to link up my calendar to Thunderbird/Lighting.  It did not go too well.  Several problems:

-  On my laptop, when I attach to my calendar, Thunderbird just comes up with horrible looking errors:

[Exception... "Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [calIRecurrenceItem.icalProperty]"  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: file:///C:/Documents%20and%20Settings/davidb/Application%20Data/Thunderbird/Profiles/b5mk9ta3.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calItemBase.js :: anonymous :: line 604"  data: no]

-  On my desktop, it comes up, but apparently the rules used by Outlook and Thunderbird for handling alarms caused all of my reminders to start triggering again...so, after about 40 repeating event alerts appeared, I took evasive action and killed both Thunderbird and Outlook and went back to Outlook for the moment.

Given what a nice, elegant migration path this would give people who are using CGP, are there any thoughts about where this is going and if it will be available at some point?  It looks possible to do a one-way cut (ie, export, then import back in) but that means a mixed-world environment with shared calendars (Outlook and Thunderbird) may not work so well.

Cheers.
Comment 37 Bas van den Bosch 2008-05-13 21:46:36 PDT
Your ics probably has a rdate with a PERIOD in it, this is a known bug (bug 427617. You could manually edit the ics with wordpad and delete the PERIOD in it. This is dataloss but not really severe afaik. 
Comment 38 Bas van den Bosch 2008-05-13 21:50:55 PDT
BTW, I've been using communigate with Thunderbird and Lightning ever since bug 327602 was fixed in januari 2007 and didn't have this problem.
Comment 39 David Birnbaum 2008-05-14 14:35:53 PDT
I have no doubt that something Outlook has put in place is causing the problem; alas, editing ICSs manually isn't a very elegant (or scalable) solution for a mixed-mode (Outlook + Thunderbird + Webmail) or migration plan (100 Outlook users to Thunderbird).  For a greenfield application, it looks like it might work just dandy, but unfortunately Outlook has ruled the roosts I have to co-exist in until now, so suggestions for automated and preferably transparent coexistence will be needed if this is going to be a corporate option anytime soon.
Comment 40 James Carroll 2008-07-16 07:42:30 PDT
URL is broken.
Comment 41 mr 2009-01-22 04:06:30 PST
I get the same error message as David described in Comment #36, but with
calItemModule.js -> calIcsParser.js :: ipParseFromStream :: line 185 data: no

However, I don't have any RDATE in my imported .vcs file, so it's not the described bug 427617. Are there similar things that could be edited in order to import it in Lightning?

(The .vcs was exported from Outlook 2003 with Outlook2Vcal v 3.2 available at https://gforge.bamafolks.com/projects/outlook2vcal , since the old URL is broken.)


I have also tried to import a .csv file (comma separated values) from Outlook 2003 into Lightning, but the calendar remains totally empty! Why? (No, I didn't forget to 'show' this calendar as is mentioned in some FAQ.)

The first line in my .csv file has the following entries, can eny of them ruin the Lightning import?

"Subject","Start Date","Start Time","End Date","End Time","All day event","Reminder on/off","Reminder Date","Reminder Time","Meeting Organizer","Required Attendees","Optional Attendees","Meeting Resources","Billing Information","Categories","Description","Location","Mileage","Priority","Private","Sensitivity","Show time as"


It surprises me that none of the two import methods above works, because there must be thousands of users who needs them. I looked forward to migrating from M$ to Mozilla, but I still can't use it.
Comment 42 Stefan Sitter 2009-01-22 08:43:51 PST
(In reply to comment #41)

Lightning doesn't support vCalendar format. If you want to import vCalendar files try the ".vcs Support" extension. <https://addons.mozilla.org/thunderbird/addon/4721>.

Other users successfully used FreeMiCal or other tools to export from Outlook into the iCalendar format that is supported by Lightning. <http://sourceforge.net/projects/freemical>
Comment 43 mr 2009-01-22 11:59:33 PST
The ".vcs Support" extension is what I used for .vcs files, and I also tried the built-in .ics import function - sorry, I forgot to mention it.

Anyway, after some more googling I found some tips that I never found within the Lightning descriptions, namely this:
  http://forums.mozillazine.org/viewtopic.php?t=481979
In the post from March 10th, 2007, the writer 'google1' says:

'Ok - i've finally found a way to do this.
[...]
Firstly your outlook calendar must be set to US date format, ie mm/dd/yy.
If it isn't, then go to control panel & change it in your regional settings[...]
Now, go to Oultook and choose File/Import & Export/Export to a File
Select "Comma Separated Values (DOS)" - this is important as "CSV (Windows)" does not appear to work. [...]
With Sunbird, import the csv file - this should work.
Don't edit the csv file with Excel - this will render it useless for import into Sunbird. [...]
the same works with Lightning 0.3.1'

After first having an "out of memory" in the .vcs plugin, and then having all the calendar entries finally appear in Lightning but with removed special characters, and finally losing the whole calendar in the next program start, I ended up importing my Outlook calendar in Google Calendar instead. I then connected it with Lightning via the "Provider for Google Calendar" which seems to work fine,
https://addons.mozilla.org/en-US/thunderbird/addon/4631
but anyway - if the above description is correct I see several behaviours that give users problems, but could be fixed to make the application feel much more reliable:

* the importer only accepts US date format, without telling it

* invalid entries are skipped without a word

* a whole calendar file can be skipped without a word

* the CSV(DOS) version of the Outlook files seems to support only letters A-Z, which is enough for English, Hawaiian, Swahili - all other language needs special characters

* people will want to be able to edit in Excel etc before importing
Comment 44 Teester 2009-01-22 13:22:12 PST
(In reply to comment #43)
> The ".vcs Support" extension is what I used for .vcs files, and I also tried
> the built-in .ics import function - sorry, I forgot to mention it.

I am the author of the .vcs Support extension, and I'm interested in finding out why your file failed to import correctly into Lightning.  I have not got a copy of Outlook 2003, but files generated by Microsoft Works calendar needed a certain amount of extra attention by the extension.

Since fixing bugs in my extension is outside the remit of this bug, I would appreciate it it you could email me at vcssupport1@gmail.com, preferably enclosing a copy of the file in question, or a similar file which has the same problems so that I can find out if there is a bug in .vcs Support or if there are special steps that I need to include to process files generated by Outlook 2003.
Comment 45 rudih 2009-04-08 02:43:16 PDT
I want to go back to the original question, importing from Outlook to Lightning.
For me, it does not work (using TB 2.0.0.21 and Lightning 0.9) using a .csv (windows) file from Outlook 2003. Apart from the remarks in comment #42 (the importer only accepts US date format, without telling it, invalid entries are skipped without a word and a whole calendar file can be skipped without a word).
So I tried something else. From a new installation (an empty calendar), create some events in Lightning and export them as .csv. Empty the calender again in Lightning, and import the just exported .csv calendar data. What happens : you get the reminders instantly (although they should not happen at that time), but not a single event shows in the calender.

Conclusion: Lightning is not able to import the .csv data it exported itself. Seems a problem to me.
Comment 46 corbin 2009-05-11 14:43:03 PDT
Are you guys for real?
Importing a CSV file is really that hard?
Comment 47 Philipp Kewisch [:Fallen] 2009-05-13 00:01:37 PDT
(In reply to comment #46)
> Are you guys for real?
> Importing a CSV file is really that hard?

Given the number of comments, it seems so. Unfortunatly, we don't have enough developers to work on this bug right now, maybe you are intereted in helping out?
Comment 48 Daryl Lee 2009-06-08 07:49:00 PDT
I'm having difficulty with importing .ics appointments.  (I'm on Thunderbird 2.0.0.21 (20090302) and Lightning 0.9.)  When I accept an appointment, it shows up on my local workstation okay, but there are then two issues.  a) I cannot remove it.  I right-click on the appointment and there is no Delete option (it's there, but grayed out).  b) It doesn't show up on my iPhone.  I use Lightning and GCal's calendar sharing feature to keep my iPhone calendar and Lightning calendar synchronized.  Appointmens set from .ics files don't show up on my iPhone; they're on the web view of GCal, but not on the iPhone.

I'm a programmer, but with no Thunderbird/Lightning experience.  I'd be glad to help if there's some help for newbie helpers.
Comment 49 Mike Kuniavsky 2009-09-30 12:42:32 PDT
I have a CSV file generated by Yahoo! calendar that breaks. Even a single line breaks the CSV parser. Here is the minimum file that creates the error:

"Subject","Start Date","Start Time","End Date","End Time","All day event","Description"
"Meeting with WN","1/7/1999","12:30 PM","1/7/1999","01:30 PM","false",""
Comment 50 Philipp Kewisch [:Fallen] 2010-02-28 11:45:04 PST
I'm closing this bug in favor of bug 549225 since this contains a lot of off-topic stuff.

*** This bug has been marked as a duplicate of bug 549225 ***

Note You need to log in before you can comment on or make changes to this bug.