Sync toolkit error console with xpfe

RESOLVED WONTFIX

Status

defect
RESOLVED WONTFIX
12 years ago
3 years ago

People

(Reporter: kairo, Unassigned)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

()

Bug 380786 comment #4 mentions that apparently toolkit Error Console has not picked up fixes that were made in the xpfe version. We should get those ported over so that we can kill off the xpfe version finally.

From my inspection of cvs logs, we (may) need to port bug 158475, bug 303142, bug 179268, bug 282253, bug 288544 and bug 290429.

I've set the URL of this bug to a buglist of all those.
bug 158475 - In toolkit.
bug 303142 - needs porting.
bug 179268 - needs porting.
bug 282253 - needs porting.
bug 288544 - needs porting.
bug 290429 - needs porting.
> bug 158475 - In toolkit.
Anyway this code is being rewritten as part of Bug 385092
Product: Firefox → Toolkit
(In reply to comment #1)
> bug 303142 - needs porting.

Instead of changing the ID, I'd rather change the icon's file name, though (won't invalidate as many extensions/CSS hacks/etc.).

> bug 179268 - needs porting.
> bug 282253 - needs porting.

Where the latter is a regression fix for the former, so make sure to port both at the same time.

Besides: This bug's a DUPE of bug 344955.
Depends on: 344955
Version: unspecified → Trunk
The Error Console has been removed in favor of the Browser Console (see Bug 1278368), and the component is going to be removed.  If this bug is also relevant in the Browser Console, please reopen and move this into Firefox -> Developer Tools: Console.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
I am mass-reopening and re-componenting every single one of the Toolkit:Error Console bugs that appear to have been closed without anyone even *glancing* at whether they were relevant to the Browser Console.

If you want to close a whole bunch of old bugs -- FOR ANY REASON -- it is YOUR RESPONSIBILITY to check EVERY SINGLE ONE OF THEM and make sure they are no longer valid.  Do not push that work onto the bug reporters.

(It's okay to close bugs that haven't been touched in years when they don't have enough information for you to figure out whether the problem is still relevant to the current software - the reporter probably isn't coming back to clarify.  But that is the ONLY situation where it is okay.)

(I'm going to have to do this in two steps because of the way the "change several bugs at once" form works.  Apologies for the extra bugspam.)
Status: RESOLVED → REOPENED
Component: Error Console → Developer Tools: Console
Product: Toolkit → Firefox
Resolution: WONTFIX → ---
The Error Console feature was removed entirely from the tree in Bug 1278368 and the bugzilla component is now being removed. We’ve migrated bugs that seem to also affect the Browser Console into the devtools component, please move this over if it was missed.
Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Component: Developer Tools: Console → Error Console
Product: Firefox → Toolkit
Resolution: --- → WONTFIX
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.