remove xpfe/communicator from Thunderbird build

RESOLVED FIXED

Status

RESOLVED FIXED
11 years ago
10 years ago

People

(Reporter: kairo, Assigned: kairo)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

11 years ago
Thunderbird currently still goes into xpfe/communicator in its build, see http://mxr.mozilla.org/seamonkey/source/xpfe/Makefile.in#53

We should get rid of this so that xpfe/communicator can ultimately be removed from the source (SeaMonkey uses its own version from suite/ anyways).

While at this, we should probably look into the places where we are using communicator files in Thunderbird as well, as I guess that http://mxr.mozilla.org/seamonkey/source/mail/base/jar.mn#133 (and 134) don't actually work, as communicator is probably not registered in toolkit.jar but only in comm.jar so those two files are probably not actually used anywhere from that place.
(Assignee)

Comment 1

11 years ago
I just did a build of Thunderbird without entering xpfe/components and the two toolkit.jar files removed in the location pointed out above, and everything seemed to work (once I added registration of the communicator chrome package to mail/bar/jar.mn).

I'll file a patch tomorrow, this should make everything a lot cleaner :)
Assignee: nobody → kairo
(Assignee)

Comment 2

11 years ago
Created attachment 271023 [details] [diff] [review]
don't build xpfe/communicator for Thunderbird

This is the patch for what I mentioned above - the only thing Thunderbird still needs from xpfe/communicator is the one line that's registering the communicator chrome package, and that can easily be copied to mail/base (which I'm doing here).
Testing a build with this patch shows no errors in chrome or error console and everything seems to be working fine.
Attachment #271023 - Flags: review?
(Assignee)

Updated

11 years ago
Attachment #271023 - Flags: review? → review?(philringnalda)
I don't suppose you own a printer? It looks to me like you're breaking printing, since we include chrome://communicator/content/printing.js several places that would need chrome://global/content/printUtils.js instead. (And I really, really hope it's a drop-in replacement.)
(Assignee)

Comment 4

11 years ago
Interesting. I don't know printing too well, but as a toolkit app, it's surely better to use a toolkit file than a communicator file. printUtils rev. 1.1 says "add printUtils.js to the toolkit (copied from printing.js)" in the checkin comment, so it actually should be exchangeable (oh, and if it's referenced in files shared with SeaMonkey, we should also change it, as SeaMonkey uses toolkit as well now).
(Assignee)

Updated

11 years ago
Depends on: 387247
Comment on attachment 271023 [details] [diff] [review]
don't build xpfe/communicator for Thunderbird

I've been running with this patch so long waiting for the printing reviews to work their way up the chain, I had to look it up earlier today to see what it was, so it ought to be pretty safe :)

r=philringnalda, and thanks!
Attachment #271023 - Flags: review?(philringnalda) → review+

Comment 6

11 years ago
So if we don't ship this 0-byte file we can probably cvs remove it?
http://mxr.mozilla.org/seamonkey/source/mail/base/content/tasksOverlay.xul
The checkin comment was "empty out tasksOverlay.xul. We don't use it anymore but someone else (in a file we don't fork) may try to load it."
(Assignee)

Comment 7

11 years ago
Steffen:
That's why I haven't marked this bug FIXED yet ;-)
(Assignee)

Comment 8

11 years ago
OK, checked in, everything's green, and r/sr/agreement on IRC from Phil and mscott for the CVS removal of tasksOverlay.xul
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Duplicate of this bug: 222049
You need to log in before you can comment on or make changes to this bug.