Tooltip extends downward into TaskBar

RESOLVED FIXED

Status

()

Firefox
General
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: Jim Jeffery not reading bug-mail 1/2/11, Assigned: Neil Deakin)

Tracking

Trunk
x86
Windows Vista
Points:
---
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a7pre) Gecko/2007070608 Minefield/3.0a7pre Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a7pre) Gecko/2007070608 Minefield/3.0a7pre Firefox/3.0

Visiting the site in the URL, and hovering over a link near the bottom of the screen results in some tooltips, if large enough, to display down - covering the taskbar and in some cases cutting off a line or two of text. 

The tooltip should be displayed 'upward' if the tip is near the bottom of the display area. 

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Actual Results:  
Tooltip displays wrong, goes down over the taskbar.

Expected Results:  
Should display upward on tips located at the bottom of the screen. 

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a7pre) Gecko/2007070608 Minefield/3.0a7pre Firefox/3.0 ID:2007070608
Vista HP
(Reporter)

Updated

11 years ago
Version: unspecified → Trunk

Updated

11 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

11 years ago
Depends on: 279703

Updated

11 years ago
Depends on: 386390
No longer depends on: 279703
Why did you mark this bug as "depends on" bug 386390?
(In reply to comment #1)
> Why did you mark this bug as "depends on" bug 386390?

I didn't that I know of.  I don't know how it could of snuck in when I filed.



Sorry, not you Jeffrey. "supernova_00" did that, my question was addressed to him/her.

Comment 4

11 years ago
I believe that bug regressed this because on the mozillazine forums it was stated that the tooltips were fine (except for the 386390 bugs) then after that checkin, this bug was reported.
(In reply to comment #4)
> I believe that bug regressed this because on the mozillazine forums it was
> stated that the tooltips were fine (except for the 386390 bugs) then after that
> checkin, this bug was reported.

I doubt that bug would have had anything to do with this, so unless you have evidence that this specific bug was tested before bug 386390's landing, but after bug 279703's, I'd rather you not jump to conclusions :). It's much more likely that this is a regression from bug 279703.
No longer depends on: 386390
Created attachment 271293 [details]
screen shot showing problem

100% reproducible in nightly trunk build from 20070705, as shown 
in this screen shot.  Also notice the size of the popup!
BTW, the screen shot was taken while viewing this very bug.

Comment 7

11 years ago
(In reply to comment #6)
> Created an attachment (id=271293) [details]
> screen shot showing problem
> 
> 100% reproducible in nightly trunk build from 20070705, as shown 
> in this screen shot.  Also notice the size of the popup!
> BTW, the screen shot was taken while viewing this very bug.
> 
That is bug 386390 which is fixed in today's build. Please update minefield
(Assignee)

Comment 8

11 years ago
Created attachment 272681 [details] [diff] [review]
Evil fix

This is caused by the famous bug 228673. The preferred height is being returned as one line, then the child is laid out which sets its size to the real size needed, several lines.

This is a workaround style fix which I don't really like but at least can be removed again once inlines and xul boxes work better together. The patch is bug 388112 is also needed.
Assignee: nobody → enndeakin
Status: NEW → ASSIGNED
(Assignee)

Comment 9

11 years ago
Comment on attachment 272681 [details] [diff] [review]
Evil fix

OK, I think this should be ok for now. I can revisit this one day when bug 228673 is fixed.
Attachment #272681 - Flags: superreview?(bzbarsky)
Attachment #272681 - Flags: review?(bzbarsky)
Comment on attachment 272681 [details] [diff] [review]
Evil fix

OK, but make a note in the boxobject bug that this code should be removed.
Attachment #272681 - Flags: superreview?(bzbarsky)
Attachment #272681 - Flags: superreview+
Attachment #272681 - Flags: review?(bzbarsky)
Attachment #272681 - Flags: review+
(Assignee)

Updated

11 years ago
Attachment #272681 - Flags: approval1.9?
Comment on attachment 272681 [details] [diff] [review]
Evil fix

a=bzbarsky
Attachment #272681 - Flags: approval1.9? → approval1.9+
(Assignee)

Comment 12

11 years ago
Checked in. Will need to add something for this to the largemenu.xul test
Flags: in-testsuite?
(Assignee)

Updated

11 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.