rename fxnewref-*-tbox to fx-*-tbox

RESOLVED FIXED

Status

P2
minor
RESOLVED FIXED
11 years ago
5 years ago

People

(Reporter: Gavin, Assigned: preed)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

'Cause it doesn't really make sense to have a tinderbox with a specific version number in it's name.
(Assignee)

Comment 1

11 years ago
I had Gavin assign this to me so I don't forget; I'll do it some night when nobody's looking.

I named it fx3- to keep it separate from fx-linux-tbox for now (in case we need to roll back).
Status: NEW → ASSIGNED
Priority: -- → P2
Created attachment 271287 [details] [diff] [review]
Changes to be reverted

This is what I did when fx3-linux-tbox came online.
(Assignee)

Comment 3

11 years ago
Renaming summary and retriaging priority.

I left the name fxnewref, so we could revert back to fx- in a hurry if we had to.

If we have no problems with fxnewref-linux-tbox after a couple weeks, we should change the machine's hostname to fx-linux-tbox.
Assignee: preed → build
Status: ASSIGNED → NEW
Priority: P2 → P3
Summary: rename fx3-linux-tbox to something that doesn't include "3" → rename fxnewref-linux-tbox to fx-linux-tbox
(Assignee)

Comment 4

11 years ago
Ditto for win32.
Summary: rename fxnewref-linux-tbox to fx-linux-tbox → rename fxnewref-*-tbox to fx-*-tbox
Assignee: build → preed
Blocks: 384624
Priority: P3 → P2
(Assignee)

Updated

11 years ago
Duplicate of this bug: 393262
(Assignee)

Comment 6

11 years ago
Created attachment 279036 [details] [diff] [review]
fxnewref-*-tbox => fx-*-tbox

tinder-config and monitoring changes to rename fxnewref-*-tbox.

The first tinder-config.pl change is to the trunk win32 configs, the second is to the test_perf configs. Included also are the monitoring changes.
Attachment #279036 - Flags: review?(nrthomas)
(Assignee)

Comment 7

11 years ago
Comment on attachment 279036 [details] [diff] [review]
fxnewref-*-tbox => fx-*-tbox

Add rhelmer, because I always forget some (part) of some config when I do these...
Attachment #279036 - Flags: review?(rhelmer)
(Assignee)

Comment 8

11 years ago
Comment on attachment 279036 [details] [diff] [review]
fxnewref-*-tbox => fx-*-tbox

Add bhearsum... here's your official "heads up!" ;-)
Attachment #279036 - Flags: review?(bhearsum)
Comment on attachment 279036 [details] [diff] [review]
fxnewref-*-tbox => fx-*-tbox

Looks good to me
Attachment #279036 - Flags: review?(rhelmer) → review+

Updated

11 years ago
Attachment #279036 - Flags: review?(bhearsum) → review+
Comment on attachment 279036 [details] [diff] [review]
fxnewref-*-tbox => fx-*-tbox

r+, with some ridiculous demands (TM).

The Linux tinder-config changes look good. Please also fix the header of tinder-config.pl on HEAD, it also refers to fxnewref-linux-tbox. [Aside: I semi-remember some grumbling from graphs people about discontinuous data resulting from these GraphNameOverride changes. Should we do this the same next time ?]

I don't see any win32 tinder-config changes to match this ...

>Index: Tier1_Firefox.txt
>===================================================================
>RCS file: /cvsroot/mozilla/tools/tinderbox-configs/monitoring/Tier1_Firefox.txt,v
>retrieving revision 1.11
>diff -u -8 -r1.11 Tier1_Firefox.txt
>--- Tier1_Firefox.txt	28 Aug 2007 11:46:54 -0000	1.11
>+++ Tier1_Firefox.txt	30 Aug 2007 22:58:11 -0000
>@@ -1,6 +1,6 @@
>-fxnewref-linux-tbox|Depend
>-bl-bldlnx03|perf test|fxnewref-linux-tbox
>-bl-bldxp01|perf test|fxnewref-win32-
>+fx-linux-tbox|Depend
>+bl-bldlnx03|perf test|fx-linux-tbox
>+bl-bldxp01|perf test|fx-win32-tbox
> bm-xserve08|Depend
> fxdbug-linux-tbox|Depend
>-fxnewref-win32-|Depend
>+fx-win32-|Depend

Going to put them up for review too ? Finally, the last line should be 
  fx-win32-tbox|Depend
Attachment #279036 - Flags: review?(nrthomas) → review+
(Assignee)

Comment 11

11 years ago
(In reply to comment #10)
> (From update of attachment 279036 [details] [diff] [review])
> r+, with some ridiculous demands (TM).
> 
> The Linux tinder-config changes look good. Please also fix the header of
> tinder-config.pl on HEAD, it also refers to fxnewref-linux-tbox. [Aside: I
> semi-remember some grumbling from graphs people about discontinuous data
> resulting from these GraphNameOverride changes. Should we do this the same next
> time ?]

I actually did that on purpose; since these are different configurations, the discontinuous data is useful to indicate that there was indeed a change. On the other hand, if you can't annotate and/or document that change, then 

> I don't see any win32 tinder-config changes to match this ...

Ahh yes... I actually thought win32 would "just work," because I'll change all that in DNS, but there's an fxnewref hanging around (ironically in the graph override variable); I'll change that too.

> Going to put them up for review too ? Finally, the last line should be 
>   fx-win32-tbox|Depend

So it should...
Blocks: 394904
(Assignee)

Comment 12

11 years ago
Landed all this and (after being closed), the tree is open again.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.