width of left pane ('all folders' and 'agenda/todo/calendar' - new 'mode toolbar' - ) is not set properly at startup

VERIFIED FIXED in 0.7

Status

--
minor
VERIFIED FIXED
11 years ago
11 years ago

People

(Reporter: juergen.edner, Assigned: ssitter)

Tracking

unspecified
x86
Windows XP
Bug Flags:
blocking-calendar0.7 +

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: Thunderbird v2.0.0.4 (20070604) / Lightning v0.7pre (2007070403)

After installing the latest nightly build of lightning v0.7pre (2007070403) the new mode toolbar appears at the bottom of the left pane right under the 'all folder' view.
If I resize this left pane, independently if it shows the 'all folders' view in Thunderbird or the 'agenda/todo/calendar' in Lightning, this change doesn't persist after a restart of Thunderbird. It always starts with the default width.

Reproducible: Always

Steps to Reproduce:
1. open Thunderbird
2. resize the width of the left pane
3. restart Thunderbird

or

1. start Thunderbird
2. switch to the calendar view
3. resize the width of the left pane
4. restart Thunderbird
5. switch to the calendar view

Actual Results:  
If I resize this left pane, independently if it shows the 'all folders' view in Thunderbird or the 'agenda/todo/calendar' in Lightning, this change doesn't persist after a restart of Thunderbird. It always starts with the default width.

Expected Results:  
The width of the left pane should persist and automatically set at startup.
I think this is my turn...
Assignee: nobody → michael.buettner
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-calendar0.7+

Comment 2

11 years ago
This is an incredibly simple, yet infuriating little bug.  In the last few nightly builds the default startup size for the folder sidebar has gotten smaller and smaller.
(Assignee)

Comment 3

11 years ago
Created attachment 271546 [details] [diff] [review]
rev0 - persist width on box

Sorry for stealing the bug. I just tested this patch and it works fine.
Assignee: michael.buettner → ssitter
Status: NEW → ASSIGNED
Attachment #271546 - Flags: review?(michael.buettner)

Comment 4

11 years ago
Confirmed.  Fix from #3 works.

Comment 5

11 years ago
Would you make it save two different widths for the left pane:  one for mail mode and one for calendar mode?  Or does this require a new bug request?

My mailbox names (in mail mode) are much wider than my calendar names (in calendar mode).  Such an enhancement would allow me to show more detail in the month view by making the left pane narrower in calendar mode.
Comment on attachment 271546 [details] [diff] [review]
rev0 - persist width on box

>+  <vbox id="ltnModeBox" insertbefore="folderPaneBox" persist="collapsed width">
r=mickey.
Attachment #271546 - Flags: review?(michael.buettner) → review+
patch checked in on trunk and MOZILLA_1_8_BRANCH

-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
(In reply to comment #5)
> Would you make it save two different widths for the left pane:  one for mail
> mode and one for calendar mode?  Or does this require a new bug request?
Could you please file an enhancement bug for this request? Although I'm totally with you, I'd suggest to just go ahead with this patch and address the request separately. The reason is that remembering different widths involves more than adding just a 'persist' attribute (which I just forgot). Thanks for all the valuable feedback, BTW.

Comment 9

11 years ago
Thanks, I created bug 387575 for two different widths of the left pane.

Updated

11 years ago
Duplicate of this bug: 387851

Comment 11

11 years ago
adding "mode toolbar" in summary for beter bugzilla search
Summary: width of left pane ('all folders' and 'agenda/todo/calendar') is not set properly at startup → width of left pane ('all folders' and 'agenda/todo/calendar' - new 'mode toolbar' - ) is not set properly at startup
Target Milestone: --- → 0.7

Comment 12

11 years ago
Verified in lightning build 2007071904, task is fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.