Last Comment Bug 387515 - RE: Account Settings / Server Settings suggestion
: RE: Account Settings / Server Settings suggestion
Status: RESOLVED DUPLICATE of bug 215941
:
Product: Thunderbird
Classification: Client Software
Component: Account Manager (show other bugs)
: unspecified
: x86 Windows 2000
: -- enhancement (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-09 22:13 PDT by Terry Mester
Modified: 2008-01-01 18:11 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Terry Mester 2007-07-09 22:13:02 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: Thunderbird version 2.0.0.4 (20070604)

I wish to recommend that you change the way "Fetch Headers only" operates.   It would be better to have all enabled Message Filters be applied to all Headers as they are downloaded.  The current setup is inconvenient in that it requires Messages to be MANUALLY downloaded or deleted.  I have no doubt that everyone would agree that it would be preferable to have Messages AUTOMATICALLY  downloaded or deleted via Message Filters.  I personally wish to be able to "Delete from POP Server" known Junk Messages without having to download them, but this is not presently possible.  This ability to delete without downloading is important for someone with 'direct dial' Internet connection.  Message Filters of course can be disabled for anyone who wouldn't want them applied to Headers.

It is also necessary that the "Leave Messages on Server" function in Server Settings be made subject to the "Delete from POP Server" function in Message Filters.  When using "Fetch Headers only", you of course need to "Leave Messages on Server" for a period of time in order to download or delete them.  However, it is necessary that it be possible to delete the Messages from the POP Server via Message Filters.  This therefore makes it necessary that the "Delete from POP Server" take precedence over the "Leave Messages on Server" function in Server Settings.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Comment 1 Gyula Zsigri 2007-08-14 05:00:22 PDT
> It is also necessary that the "Leave Messages on Server" function in Server
> Settings be made subject to the "Delete from POP Server" function in Message
> Filters.

In Thunderbird 2.*, the "Delete from POP Server" option does not work at all if "Leave Messages on Server" is checked in Server Settings.  This is really annoying.  I am using Thunerbird both at work and at home, so I need to leave the messages on the server.  However, there are some unwanted messages that I do not want to keep on the server.  In Thunderbird 1.*, I could use a message filter that deleted them from the POP server after with a minor annoyance that the messages were downloaded before the message filter deleted them.  In Thunderbird 2.*, the unwanted messages are still downloaded as in Thunderbird 1.* but they are no longer removed.

Stept to Reproduce:

1. Install Thunderbird 2.* on two machines with the same user account.
2. Check "Leave Messages on Server" on both machines.
3. Create a message filter on both machines to delete messages from the POP server whose subject line contains "Not Deleted From POP Server".
4. Send a message to yourself with "Not Deleted From POP Server" in the subject line.
5. Still at the first machine, download the messages again to receive the message you have just written to yourself.  Yo will.
6. Go to the other machine.  Now you are hoping that you won't be able to download your message with the "Not Deleted From POP Server" subject line.  You will be disappointed to see that the message was not deleted from the POP server.
Comment 2 Gyula Zsigri 2007-08-17 02:10:30 PDT
(In reply to comment #1)
> In Thunderbird 2.*, the "Delete from POP Server" option does not work at all if
> "Leave Messages on Server" is checked in Server Settings.

Actually, it does if you disable message quarantining in Tools : Options :
Privacy : Viruses.  See Bug 370442.
Comment 3 Terry Mester 2007-08-17 22:24:33 PDT
I'm glad that this change has been implemented with new Version 2.0.0.6 (20070728).  This is a significant help in contravening Junk Mail.  There are just three small problems which I hope can be corrected.
1) When a Message Filter is applied to a Header, the full Message for the Header should only be downloaded if "Fetch from POP Server" is selected in the Filter.  At present, if "Delete from POP Server" is applied without first applying "Delete", the full Message for the Header is automatically downloaded even if "Fetch from POP Server" isn't directed.  I hope this can be fixed.
2) The Message Header itself needs to also provide for the option of manually deleting the Message from the POP Server.  At present, if you delete the Message Header, the Message is left on the POP Server if you've chosen to "Leave Messages on Server / Until I delete them" in Account Settings.  I would suggest adding to Thunderbird the ability to check for "old" Messages on the POP Server.  At present, you need to log onto your Internet Server to delete these old Messages.   Most people wouldn't know how to do this.
3) I've discovered a small problem with the "Size" condition in Message Filters.  TBird is using the size of the Header (1KB) and not the size of the actual Message.
Comment 4 Terry Mester 2007-08-21 19:01:46 PDT
(In reply to comment #3)
> 3) I've discovered a small problem with the "Size" condition in Message
> Filters.  TBird is using the size of the Header (1KB) and not the size of the
> actual Message.
> 
Can any Mozilla programmer verify if they've been assigned to fix this Bug?  Have you been able to identify the source of this problem?
Comment 5 Terry Mester 2007-08-23 14:24:25 PDT
(In reply to comment #4)
> (In reply to comment #3)
> > 3) I've discovered a small problem with the "Size" condition in Message
> > Filters.  TBird is using the size of the Header (1KB) and not the size of the
> > actual Message.
> > 
> Can any Mozilla programmer verify if they've been assigned to fix this Bug? 
> Have you been able to identify the source of this problem?
> 
Has nobody been assigned this Bug?

I want to suggest a small change to the "Tag" feature in the Action Box.  You need to add the option of "Remove all Tags".  This is necessary so that users can CHANGE the Tag of a Message.
Comment 6 Wayne Mery (:wsmwk, NI for questions) 2007-12-31 09:46:20 PST
(In reply to comment #5)
> (In reply to comment #4)
> > (In reply to comment #3)
> > > 3) I've discovered a small problem with the "Size" condition in Message
> > > Filters.  TBird is using the size of the Header (1KB) and not the size of the
> > > actual Message.
> > > 
> > Can any Mozilla programmer verify if they've been assigned to fix this Bug? 
> > Have you been able to identify the source of this problem?
> > 
comment 0
> "Delete from POP Server" known Junk Messages without having to download them,
but this is not presently possible. 

this is basically bug 215941.  Duping.


> Has nobody been assigned this Bug?

see "assigned to:"


> I want to suggest a small change to the "Tag" feature in the Action Box.  You
> need to add the option of "Remove all Tags".  This is necessary so that users
> can CHANGE the Tag of a Message.

please only one issue per bug. If you have other issues or requests, please file a new bug.

*** This bug has been marked as a duplicate of bug 215941 ***
Comment 7 Terry Mester 2008-01-01 18:11:10 PST
> > > 
> comment 0
> > "Delete from POP Server" known Junk Messages without having to download them,
> but this is not presently possible. 
> 
> 
Actually it is possible.  With Fetch Headers only selected in Account Settings, in a Message Filter you simply choose the following Actions:
"Delete Message"
"Delete From POP Server"
The Message then gets deleted from the Server without getting downloaded.  This is wonderful for those using Dialup.

Note You need to log in before you can comment on or make changes to this bug.