Closed Bug 387843 Opened 15 years ago Closed 15 years ago

Items missing from Tab/Shift+Tab order in Thunderbird's Page Setup dialog

Categories

(Core :: DOM: UI Events & Focus Handling, defect)

x86
All
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: jdiggs, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: access, regression)

Steps to reproduce:

1. File menu -> Page Setup
2. With focus in the Orientation radio button group, press Tab

Expected results:  Focus would move to the next control.
Actual results: Focus does not move.
Notes:  Shift+Tab works here; Tab works as long as focus is not in the radio button group.

3. Move focus to the Margins & Header/Footer page.
4. Use Shift+Tab to move among all of the controls

Expected results: Focus would move among all of the controls on the page
Actual results: Focus skips over the four "margin" entries.
Note: Tab works here as expected.
Same happens for the latest trunk build on Windows.
Component: General → Mail Window Front End
OS: Linux → All
QA Contact: general → front-end
Conveniently, it doesn't much matter whether we're currently using the toolkit version of printPageSetup.xul or the xpfe version, since Fx, Tb, and SeaMonkey are all broken - apparently something regressed whatever part of bug 281545 fixed this.
Component: Mail Window Front End → Keyboard: Navigation
Keywords: regression
Product: Thunderbird → Core
QA Contact: front-end → keyboard.navigation
Is this still happening in today's trunk build (after the patch for bug 387720 landed)?
Mmh, still happening with a fresh cvs trunk build. When I'm inside the first tab of the dialog and hit the tab key it jumps to the first element (portrait mode) but after that the tab key has no more effect. It stays at this element.
1-4 WFM version 3.0a1pre (2007071705)

(however, shift+tab doesn't work going from compose body back to subject.)
The original bug is confirmed fixed.  Thanks!

I can also confirm Wayne's bug.
WFM based on comments above.
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → WORKSFORME
Component: Keyboard: Navigation → User events and focus handling
You need to log in before you can comment on or make changes to this bug.