Closed Bug 388019 Opened 13 years ago Closed 13 years ago

<a name> is broken (clicking anchor link doesn't scroll to it)

Categories

(Core :: Layout, defect, P1)

defect

Tracking

()

RESOLVED FIXED
mozilla1.9alpha8

People

(Reporter: Peter6, Assigned: dbaron)

References

Details

(Keywords: regression)

Attachments

(3 files, 1 obsolete file)

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007071301 Minefield/3.0a7pre ID:2007071301

repro:
go to http://forums.mozillazine.org/viewforum.php?f=23
press on a last link (right column)

result:
the page won't scroll to the anchor
Product: Firefox → Core
QA Contact: general → general
Attached file testcase (obsolete) —
Summary: <a name> is broken → <a name="aNumber"> is broken
Summary: <a name="aNumber"> is broken → <a name> is broken
Attachment #272161 - Attachment is obsolete: true
regressionwindow
works in 20070712_1605_firefox-3.0a7pre.en-US.win32
fails in 20070712_1737_firefox-3.0a7pre.en-US.win32

http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=1184281500&maxdate=1184287019

bug 66619 ?
Blocks: 66619
Component: General → Layout
QA Contact: general → layout
Summary: <a name> is broken → <a name> is broken (clicking anchor link doesn't scroll to it)
Attached file testcase
<a name="abc"></a> 
with no content between the opening and closing "a" tags fails
Oh, probably UnionRect is dropping empty rects on the floor...
Attached patch patchSplinter Review
Assignee: nobody → dbaron
Status: NEW → ASSIGNED
Attachment #272221 - Flags: superreview?(roc)
Attachment #272221 - Flags: review?(sharparrow1)
And I wrote some mochitests for this bug and bug 66619 that I'll land as well.
Attachment #272221 - Flags: review?(sharparrow1) → review+
You can modify OS to ALL, as I am seeing it on ubuntu linux 7.04.
OS: Windows XP → All
Priority: -- → P1
Hardware: PC → All
Target Milestone: --- → mozilla1.9beta1
Duplicate of this bug: 388140
(In reply to comment #8)
> You can modify OS to ALL, as I am seeing it on ubuntu linux 7.04.
> 

Yes, I was seeing it on openSUSE Linux 10.2, in both Minefield (Firefox 3) and Suiterunner (SeaMonkey 2) but it got fixed before "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a7pre) Gecko/2007071401 SeaMonkey/2.0a1pre" - Build ID: 2007071401
Attachment #272221 - Flags: superreview?(roc) → superreview+
Checked in to trunk (along with relanding bug 66619).
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.