If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

my.sidebar - Customizable chrome page to display sidebar panels

RESOLVED WONTFIX

Status

()

Firefox
Tabbed Browser
--
enhancement
RESOLVED WONTFIX
18 years ago
a year ago

People

(Reporter: BenB, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
If you often have 10 or more browser windows open, the sidebar is an incredible
waste of space. However, I like the functionality, the panels. E.g. I like to
have headlines from various sources at one glance on request. Opening/closing
the sidebar for this doesn't seem to be the optimal solution in all cases.

It would be cool to have pages similar to <http://my.netscape.com>, which I can
open in the browser and to which I can add panels, but of course local and I
shouldn't be limited to one of those pages.

Comment 1

18 years ago
I think they are working on a floating toolbar...

Updated

18 years ago
Target Milestone: --- → Future

Comment 2

18 years ago
This seems to be a request for the sidebar to have its own detachable window -- 
resummarizing to reflect that. Clobber me if I'm wrong.

Another possibility is something similar to the `Digital Dashboard' used in IE 
and Outlook (see URL), in which bits of data of arbitrary type (HTML, RDF, SVG, 
whatever) could be arranged in a window at will, rather than just in
one-at-a-time vertical tabs as the Sidebar has them.
Summary: my.sidebar → Allow sidebar to live in its own window
(Reporter)

Comment 3

18 years ago
URL: <http://microsoft.com/solutions/km/DDdemo.htm>

Wait, aren't that just frames? Aren't panel's accessible via URL? You can find
URLs in bin/defaults/profile/panels.rdf. Indeed, loading such an URL in the main
browser window works. Now, create a framemset with your favorite panels, and
you're done. Why didn't I have this idea earlier?

Of course, this is not end-user ready. We need to provide an "editor", similar
to the customizer my.netscape.com uses (you have 3 columns, panels line up
vertically). Maybe we can even reuse some editor code (does it support frames or
something similar yet?).
(Reporter)

Updated

18 years ago
Summary: Allow sidebar to live in its own window → my.sidebar - Allow sidebar to live in its own window

Comment 4

17 years ago
Reassigning 50 Sidebar bugs to Matt.  I was told this was going to be done 
shortly about two months ago, but it clearly hasn't been.  I think that's long 
enough for all these bugs to remain assigned to nobody.

Feel free to filter all this spam into the trashcan by looking for this string 
in the message body: ducksgoquack
Assignee: slamm → matt
So basically you want the ability to add remove panels in a pseudo frameset 
format to an actual web page accessible from Mozilla's menu and stored locally. 
Well, CSS could easily do this and even make the page scrollable. Yes, it could 
be even editable by dragging and dropping from a toolbar which could appear in 
a seperate div. I think frames would be a bad way to go about this. Either 
that, or one could edit it through the old menu. Changing the title to "[RFE] 
Customizable local web page to store My Sidebar". Adding self.

Comment 6

17 years ago
*** Bug 61846 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Blocks: 61847

Updated

17 years ago
Blocks: 61848
(Reporter)

Updated

17 years ago
No longer blocks: 61847

Comment 7

17 years ago
AFAIK this request would allow multiple sidebars to be displayed simultaneously 
presumeably in columns or however the user decides.
FWIW, we have an XBL demo for dragable content.

Enumerating sidebars requires chrome privs, but you can still browse to chrome 
urls.
Summary: my.sidebar - Allow sidebar to live in its own window → Customizable chrome page to store Sidebars
(Reporter)

Comment 8

17 years ago
(Please leave the summary as is. Thanks.)
Summary: Customizable chrome page to store Sidebars → my.sidebar - Allow sidebar to live in its own window
(Reporter)

Comment 9

17 years ago
(timeless is right - the summary is misleading. Changing. However, in the
future, please leave the name of the bug - "my.sidebar" - there.)
Summary: my.sidebar - Allow sidebar to live in its own window → my.sidebar - Customizable chrome page to display sidebar panels

Comment 10

17 years ago
spam : changing qa to sujay (New Sidebar QA)
QA Contact: shrir → sujay

Comment 11

16 years ago
reassigning matt's old bugs.
Assignee: matt → sgehani
Product: Browser → Seamonkey
Assignee: samir_bugzilla → nobody
Priority: P3 → --
QA Contact: sujay → sidebar
Target Milestone: Future → ---

Comment 12

8 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 13

8 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 14

8 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 15

8 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 16

8 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 17

8 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 18

8 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 19

8 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but still has no comment since the inception of the SeaMonkey project 5 years ago.

Because of this, we're resolving the bug as EXPIRED.

If you still can reproduce the bug on SeaMonkey 2 or otherwise think it's still valid, please REOPEN it and if it is a platform or toolkit issue, move it to the according component.

Query tag for this change: EXPIRED-20100420
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → EXPIRED
(Reporter)

Updated

8 years ago
Status: RESOLVED → UNCONFIRMED
Component: Sidebar → General
Product: SeaMonkey → Fennec
QA Contact: sidebar → general
Resolution: EXPIRED → ---
(Reporter)

Updated

8 years ago
Assignee: nobody → cbeard
Status: UNCONFIRMED → NEW
Component: General → General
Ever confirmed: true
Product: Fennec → Extend Firefox
QA Contact: general → general
Version: Trunk → unspecified
This bug was sitting in a component that is defunct, and is being removed from bmo. Moving to Firefox: Tabbed Browser. This one is for the component's triage lead to make a decision on as to priority or to close.
Assignee: cbeard → nobody
Component: General → Tabbed Browser
Flags: needinfo?(jaws)
Product: Extend Firefox → Firefox
We don't have any plans for a floating sidebar, detachable sidebar, or extra enhancements to the current sidebar at all right now and no future plans either.
Status: NEW → RESOLVED
Last Resolved: 8 years agoa year ago
Flags: needinfo?(jaws)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.