Undockable My Sidebar - in a new window

NEW
Unassigned

Status

enhancement
19 years ago
11 years ago

People

(Reporter: netdragon, Unassigned)

Tracking

(Blocks 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

19 years ago
My friend was complaining to me about the My Sidebar, so I think that I will 
add this bug. Therefore - for him ;-) - the sidebar should be able to be 
undocked from the browser window by right clicking on My Sidebar. Then you can 
drag it around, etc. When you bring it back to the window it catches on (like 
undocable toolbars for windows programs).

He was complaining that he hates MSIE's toolbars, and that all the stuff on My 
Sidebar should be seperate. BTW - he loves NS 4.x (go figure). There is already 
a bug to make the My Sidebar be able to be loaded onto a web page, but no bug 
for this that I know of. 

BTW - I know you are going to mark it duplicate of something. So go ahead, make 
my day ;-)
(Reporter)

Updated

19 years ago
Blocks: 61847
(Reporter)

Updated

19 years ago
Blocks: 61848

Comment 1

19 years ago
dup of 38805 "my.sidebar - Allow sidebar to live in its own window"

*** This bug has been marked as a duplicate of 38805 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 2

19 years ago
vrfy dupe
Status: RESOLVED → VERIFIED

Updated

19 years ago
No longer blocks: 61847

Updated

19 years ago
No longer blocks: 61848
(Reporter)

Comment 3

19 years ago
No no no. I wrote this bug after I replied to that one. Obviously you can tell I
do not view this as a duplicate if I did that. That bug has nothing to do with
mine. He wanted a way to view all the Sidebar content on a web page. People
wrote the summary incorrectly. Reopening. Wack me if I am misreading his bug.
Status: VERIFIED → UNCONFIRMED
Resolution: DUPLICATE → ---
confirming. not the same bug.
Assignee: asa → matt
Status: UNCONFIRMED → NEW
Component: Browser-General → Sidebar
Ever confirmed: true
QA Contact: doronr → shrir
BTW: This is what Netscape implemented for AIM. But it is not in Mozilla.

Comment 6

19 years ago
spam : changing qa to sujay (New Sidebar QA)
QA Contact: shrir → sujay

Updated

18 years ago
Target Milestone: --- → Future

Comment 7

18 years ago
*** Bug 23215 has been marked as a duplicate of this bug. ***
*** Bug 115315 has been marked as a duplicate of this bug. ***

Comment 9

17 years ago
i have a floating sidebar/component bar. bz had a semi current copy.
unfortunately my computer is stuck in @home limbo. fwiw the archive is 4k

Comment 10

17 years ago
reassigning matt's old bugs.
Assignee: matt → sgehani
I mailed who seems to be the author of the above implementation. It looks very
good, suitable for inclusion, but I didn't try it myself. Neither did I try the
following:

<http://www.deskmod.com/?show=showskin&skin_id=11108>.

Comment 13

17 years ago
I tried the deskmod sidebar(Comment #12 URL). It is excellent.  The author of it 
is Neil Rashbrook.  He seems to be the project owner of XULmine.

<http://xulmine.mozdev.org/>

Comment 14

17 years ago
SHIMODA 'Piro' Hiroshi who is the author of "Sidebar Window" made the patch. It
incorporates his product into Mozilla.I attach this patch as a substitute for
him.

Comment 17

17 years ago
It is a supplement. "Sidebar Window" is called "Floating sidebar".

Updated

17 years ago
Summary: [RFE] Undockable My Sidebar - in a new window → Undockable My Sidebar - in a new window

Comment 18

17 years ago
Now "Sidebar window" by piro is here.
http://white.sakura.ne.jp/~piro/xul/_sidebar.en.html
(Reporter)

Comment 19

17 years ago
Does bug 183333 depend on this?
no, unrelated
(Reporter)

Comment 21

17 years ago
I am not sure if I agree because for the sidebar to be able to open up on
left-screen hover, it needs to be removed from the window so that it can pop
open above the web page's frame (just like the taskbar does in windows) and not
interfere with the size of the web page, and also dissappear when you move the
mouse away.

I'll draw a picture of what I'm talking about in bug 183333 since I think I need
to clarify what I'm asking for.
(Reporter)

Updated

17 years ago
Blocks: 183333
Product: Browser → Seamonkey
No activity (other than CC change and mass-transfer from Browser to Seamonkey later renamed M.A.Suite) since 2002.

Anyone still interested in seeing this bug fixed?
Anyone still willing to fix this bug?

Please speak up if you are.
No reply to comment #22 in 25 days -- resetting A+QA
Assignee: samir_bugzilla → nobody
QA Contact: sujay → sidebar
Priority: P3 → --
Target Milestone: Future → ---
You need to log in before you can comment on or make changes to this bug.