Closed Bug 388167 Opened 15 years ago Closed 3 years ago

Hiding the first toolbar leads to a surplus line (Classic: 1px, Luna: 2px)

Categories

(Core :: Widget: Win32, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: zeniko, Unassigned)

References

Details

Attachments

(2 files)

No regression from bug 243078 or one of its dependencies, though - this never looked correctly for Toolkit 1.8 applications, either (Classic: 1px, Luna: 1px).

The correct fix would probably be to not treat the first toolbar in a toolbox differently at all and just have the toolbox eat surplus lines at the top through a negative margin.
The easiest way around this issue is indeed to simply use a negative margin on the toolbox which hides the surplus separator line from the natively styled toolbar resp. a bogus border from the CSS styled toolbox (where the separator above the first toolbar is actually wanted).

This has the consequence of an unfortunate dependency on toolbar.css, but this may be unavoidable as I see no other way of hiding the top of an element than by a negative margin which can't be set from an nsITheme implementor.

The alternative to this treat-all-toolbars-the-same approach would involve figuring out whether a toolbar is indeed the first visible one, which isn't my piece of cake, though (see bug 337771 comment #14).

Whatever happens for native themeing, the easier approach will anyway work for CSS styled toolbars (alternatively using 1px top/bottom borders for the toolbars and letting the toolbox just add a 1px ThreeDShadow border above them all).
Assignee: nobody → zeniko
Status: NEW → ASSIGNED
Attachment #272545 - Flags: superreview?(bzbarsky)
Attachment #272545 - Flags: review?(emaijala)
Comment on attachment 272545 [details] [diff] [review]
use CSS hackery to hide the top 2px from the first toolbar

>Index: toolkit/themes/winstripe/global/toolbar.css
>+  -moz-border-top-colors: ThreeDShadow ThreeDHighlight !important;
That !important is of course not meant to be there.
I'm really the wrong person to sr this.  Someone who's more familiar with UI stuff (Neil Rashbrook?) would be better.
Attachment #272545 - Flags: superreview?(bzbarsky) → superreview?(neil)
Comment on attachment 272545 [details] [diff] [review]
use CSS hackery to hide the top 2px from the first toolbar

I don't do toolkit themes, but I don't see how this hides the top of the first toolbar.
Attachment #272545 - Flags: superreview?(neil)
Attachment #272545 - Flags: review?(emaijala)
Assignee: zeniko → nobody
Status: ASSIGNED → NEW
Product: Core → SeaMonkey
Component: Themes → Widget: Win32
Product: SeaMonkey → Core
QA Contact: themes → win32
Duplicate of this bug: 526461
Windows XP isn't supported anymore.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.