Closed Bug 388878 Opened 17 years ago Closed 17 years ago

Breakpad is built but not enabled on Thunderbird trunk

Categories

(Thunderbird :: Build Config, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: ispiked, Assigned: mscott)

Details

Attachments

(1 file)

Thanks to stephend for finding this. 

The problem is that "Enabled=1" isn't getting added to application.ini because MOZILLA_OFFICIAL isn't set for some reason. Most of the Firefox tinderboxen have this set as an env. variable, and the Linux tinderbox exports it in it's mozconfig. Do the Thunderbird tinderboxen need to do the same?
the problem might be two fold:

MOZILLA_OFFICIAL is apparently not defined in the mozconfig file for the thunderbird tinderbox machines.

and

Mail\app\Makefile.in needs the following lines:

ifdef MOZILLA_OFFICIAL
DEFINES += -DMOZILLA_OFFICIAL
endif

Actually Firefox only exports MOZILLA_OFFICIAL on linux. On windows, I don't see it set in mozconfig or tinder-config.pl. 
Scott, maybe we could try what you suggested in comment 1? It sort of sucks not to have crash data for Thunderbird trunk.
Flags: blocking-thunderbird3?
I checked the build logs for the nightly tinderboxes for Firefox & Thunderbird on the trunk - all of them have MOZILLA_OFFICIAL=1 set in the environment.
Thanks Nick. I would have been pretty surprised if our official builds weren't getting MOZILLA_THUNDERBIRD defined!

patch coming up that should fix this.
Attached patch the fixSplinter Review
Port the patch benjamin made for Firefox over to Thunderbird.
Assignee: nobody → mscott
Status: NEW → ASSIGNED
Attachment #273478 - Flags: superreview?(bienvenu)
Attachment #273478 - Flags: superreview?(bienvenu) → superreview+
Status: ASSIGNED → RESOLVED
Closed: 17 years ago
Resolution: --- → FIXED
Just grabbed a tinderbox build, and this looks fixed. Enabled=1 is in applications.ini, and I successfully submitted a crash report: https://crash-reports.stage.mozilla.com/reports/report/index/8428950c-39b1-11dc-94bf-001321b0783d?date=2007-07-24-06 (no symbols because it's an hourly build).

->VERIFIED
Status: RESOLVED → VERIFIED
Flags: blocking-thunderbird3?
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: