Use default alarms defined in Google Calendar, or add support for SMS alarms

VERIFIED FIXED in 1.0b1

Status

enhancement
VERIFIED FIXED
12 years ago
8 years ago

People

(Reporter: signup, Assigned: Fallen)

Tracking

unspecified
1.0b1
Bug Flags:
wanted-calendar0.9 -

Details

Attachments

(2 obsolete attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.5) Gecko/20061201 Firefox/2.0.0.5 (Ubuntu-feisty)
Build Identifier: 

Alarms set to be used by default in Google Calendar are ignored when the provider is used. I *really* need SMS notifications. So, either make the provider honour the default alarms I set, or add support for SMS alarms. Please add this feature!

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
With the current alarm architecture, it is not (easily) possible to provide this functionality for the GData provider. I have some changes planned, I don't think I have opened a bug regarding that though.

For general SMS support, see bug 282565.
This bug loosely depends on bug 353492. I will think about how to extend the event dialog to add a field to set the type of alarm. I don't know if I can retrieve the default alarm *value*, so I don't know if I'll support a "default" alarm. Just offering a checkbox to use the default without telling the user what the default is, seems kind of pointless.

With the above mentioned bug, I would be able to support all 5 alarms that google supports.
Status: UNCONFIRMED → NEW
Depends on: 353492
Ever confirmed: true
Summary: Use default alarams defined in Google Calendar, or add support for SMS alarms → Use default alarms defined in Google Calendar, or add support for SMS alarms

Comment 3

12 years ago
To my mind the free sms sendig feature is one of the most important things that distinguish Google Calendar from other free online calendar provider. At least this is the feature which made me choose Google calendar. 
Until Lightning and gdata provider is unable to handle sms alarm type, I have to use Google Calendar directly. This is true for most of my friends, as well.
If implementing the "default" alarm type is easier than the 5 different alarm types in the technical point of view, then the use the default, without telling the user what the default is, would also be rather good.  
Posted patch Allow Different Alarm Methods - v1 (obsolete) β€” β€” Splinter Review
This patch takes care of adding an alarm type field to the event dialog. This of course doesn't remove the limitation from bug 353492, but at least allows setting the alarm type until that bug is fixed.

Note that if an sms or email alarm is set, then there will be no alarm dialog popup. This effectively means that if the item is exported, it will not have a real VALARM component. With the above mentioned bug we should also add support for different TRIGGER values, which would allow a "real" export.

I also believe that the email and sms alarms will not trigger if they are in the past, this is the way google handles their alarms.
Assignee: nobody → philipp
Status: NEW → ASSIGNED
Attachment #286286 - Flags: review?(daniel.boelzle)
(Assignee)

Updated

12 years ago
Blocks: 401263
Posted patch Allow Different Alarm Methods - v2 (obsolete) β€” β€” Splinter Review
This patch also fixes bug 401263. I wanted to get both bugs fixed and since there were some problems with the v1 patch I decided to put them together in one. I hope thats ok.

To fix bug 401263, I added a "Google Default" menuitem to the privacy menu that is selected when the item privacy is null. This item is only visible when Google Calendars are selected. Also, the confidential item is hidden when a Google Calendar is selected.
Attachment #286286 - Attachment is obsolete: true
Attachment #286478 - Flags: review?(daniel.boelzle)
Attachment #286286 - Flags: review?(daniel.boelzle)
(Assignee)

Updated

12 years ago
Duplicate of this bug: 401563
(Assignee)

Updated

12 years ago
Duplicate of this bug: 403475
Comment on attachment 286478 [details] [diff] [review]
Allow Different Alarm Methods - v2

Taking back this patch. I will be rewriting this to make the reminder type part of the core code, or at least using the newly added event dialog IDs.
Attachment #286478 - Attachment is obsolete: true
Attachment #286478 - Flags: review?(daniel.boelzle)

Comment 9

12 years ago
Full control would be wonderful, but failing that, I also feel that a "Use Google Defaults" button (without reminding me explicitly what those are) would work fine.
(Assignee)

Updated

12 years ago
No longer blocks: 401263

Comment 10

11 years ago
+1 for the "use google defaults" workaround.
Users explicitly choosing this options probably know what they are doing, and what they have set their reminders default to. 
Duplicate of this bug: 440937

Comment 12

11 years ago
I'll add my support for this feature too. It's over a year now, and I still can't use Sunbird because this basic functionality is missing.

Updated

11 years ago
Flags: wanted-calendar0.9?
This unfortunately won't make 0.9 since bug 353492 won't make 0.9. The regression risk for that bug is way too high, therefore wanted-
Flags: wanted-calendar0.9? → wanted-calendar0.9-
Umm, isn't the "add support for SMS alarms" part of the summary fixed? You can set a custom alarm of type "text message" for an event ...

Of course, the "Use default alarms defined in Google Calendar" does not work. Plus, you cannot set those custom alarms in the global settings for Lightning ...
Since the summary says "or", I'm marking this bug fixed by bug 353492. I don't think it makes sense to add extra UI to use the default alarms from google, since lightning also has default alarms, which might be confusing for new users.
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Assignee)

Updated

10 years ago
Target Milestone: --- → 1.0
verified with
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.9pre) Gecko/20100223 Calendar/1.0b2pre

and GData 0.6b2pre
Status: RESOLVED → VERIFIED

Comment 17

9 years ago
Using the 20100131 builds of Lightning and GData provider, I'm not able to SAVE any reminder with absolute date on a Google calendar. Only the relative alarm can be saved.
Maye Google Calendar does not support absolute date, but in that case, this option should not be provided to the user. Or?
These bugs are likely targeted at Lightning 1.0b1, not Lightning 1.0. If this change was done in error, please adjust the target milestone to its correct value. To filter on this bugspam, you can use "lightning-10-target-move".
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.