fetching feed reproducibly leaks

VERIFIED DUPLICATE of bug 385178

Status

()

Firefox
RSS Discovery and Preview
VERIFIED DUPLICATE of bug 385178
11 years ago
9 years ago

People

(Reporter: Ray Kiddy, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
I have a script I test for leaks with. I gave it the URL above and it leaks the same every time.

This is a completely fresh profile (except for my testing extension at http://www.wykiwyk.com/mozilla/loadAndDie/).


cmd = "NSPR_LOG_MODULES=DOMLeak:5,DocumentLeak:5,nsDocShellLeak:5 NSPR_LOG_FILE=/tmp/nspr_25471_log.txt EM_RESTART=1 /Applications/Mozilla/Minefield_3.0a7pre_20070720.app/Contents/MacOS/firefox -profile /Users/ray/mo/clean.mozilla_20070722_155733_PDT 'http://scobleizer.wordpress.com/comments/feed/' 2>&1 >/tmp/leaksgauge_25471"
Leaked outer window 1c5aef0 at address 1c5aef0.
Leaked inner window 1a8b9290 (outer 19f1c7b0) at address 1a8b9290.
 ... with URI "http://scobleizer.com/comments/feed/".
Leaked outer window 19f1c7b0 at address 19f1c7b0.
Leaked inner window 1ccd2e0 (outer 1c5aef0) at address 1ccd2e0.
 ... with URI "about:blank".
Leaked document at address 1a8f0ed0.
 ... with URI "chrome://global/content/bindings/checkbox.xml".
 ... with URI "jar:file:///Applications/Mozilla/Minefield_3.0a7pre_20070720.app/Contents/MacOS/chrome/toolkit.jar!/content/global/bindings/checkbox.xml".
Leaked document at address 24a0200.
 ... with URI "jar:file:///Applications/Mozilla/Minefield_3.0a7pre_20070720.app/Contents/MacOS/chrome/browser.jar!/content/browser/feeds/subscribe.xhtml".
 ... with URI "http://scobleizer.com/comments/feed/".
Leaked document at address 1a8e0d30.
 ... with URI "chrome://global/content/bindings/menulist.xml".
 ... with URI "jar:file:///Applications/Mozilla/Minefield_3.0a7pre_20070720.app/Contents/MacOS/chrome/toolkit.jar!/content/global/bindings/menulist.xml".
Summary:
Application: /Applications/Mozilla/Minefield_3.0a7pre_20070720.app/Contents/MacOS/firefox
URL: http://scobleizer.wordpress.com/comments/feed/
Leaked 4 out of 7 DOM Windows
Leaked 3 out of 41 documents
Leaked 0 out of 3 docshells
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 385178
Verified Duplicate.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.