Last Comment Bug 389430 - l10n CVS Account Request - Quim Perez <noguer@gmail.com>
: l10n CVS Account Request - Quim Perez <noguer@gmail.com>
Status: RESOLVED FIXED
voucher, ssh-key, form
:
Product: mozilla.org
Classification: Other
Component: Repository Account Requests (show other bugs)
: other
: x86 Linux
: -- normal with 1 vote (vote)
: ---
Assigned To: matthew zeier [:mrz]
: Dave Miller [:justdave] (justdave@bugzilla.org)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-24 11:05 PDT by Quim Perez
Modified: 2007-12-03 14:17 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
ssh public key (606 bytes, text/plain)
2007-07-25 13:29 PDT, Quim Perez
no flags Details

Description Quim Perez 2007-07-24 11:05:00 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.5) Gecko/20061201 Firefox/2.0.0.5 (Ubuntu-feisty)
Build Identifier: 

Request a CVS write access to cvs. I'm a member of the catalan team translation. Our team leader  toniher@softcatala.org ask me to be responsible of calendar's catalan translation.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Comment 1 Toni Hermoso Pulido 2007-07-25 01:30:38 PDT
Hello, I vouch him as new owner of Catalan Calendar translation. Updated wiki link: http://wiki.mozilla.org/L10n:Teams:ca

Quim, provide your SSH public key. You have more details here:
http://www.mozilla.org/cvs-ssh-faq.html

Cheers!
Comment 2 Quim Perez 2007-07-25 13:29:57 PDT
Created attachment 273841 [details]
ssh public key
Comment 3 Marcia Knous [:marcia - use ni] 2007-07-26 20:49:36 PDT
I will need the hacking form filled out and returned - www.mozilla.org/hacking/form.html. You can scan and return via email instead of faxing. Adding axel to the bug as well, he reviews these requests and provides approval.
Comment 4 Toni Hermoso Pulido 2007-08-21 10:56:23 PDT
Any progress on this? I received Quim's form as well as CC.
Cheers,
Comment 5 Axel Hecht [pto-Aug-30][:Pike] 2007-08-23 16:25:52 PDT
Could you send that mail again with a CC to me? Marcia's on vacation and there's nobody with access to her inbox ;-)
Comment 6 Reed Loden [:reed] (use needinfo?) 2007-08-23 16:28:46 PDT
Is calendar localization done in the main tree or in the l10n tree?
Comment 7 Axel Hecht [pto-Aug-30][:Pike] 2007-08-23 16:39:33 PDT
/l10n it is, adjusting summary.
Comment 8 Joaquim Perez 2007-08-24 00:27:29 PDT
Axel Hecht, I just need access to write in /l10.  I have sent my cvs contributor form to you.
Cheers
Comment 9 Toni Hermoso Pulido 2007-09-07 08:34:51 PDT
Sorry for bugging. Any news?
Comment 10 Marcia Knous [:marcia - use ni] 2007-09-07 09:42:03 PDT
If Axel can let me know that he got the form or you can resend to marcia@mozilla.org, I can move this one along. Thanks.
Comment 11 Marcia Knous [:marcia - use ni] 2007-09-07 10:56:01 PDT
I have received the CVS form. Over to server-ops for l10n account creation.
Comment 12 Axel Hecht [pto-Aug-30][:Pike] 2007-09-07 10:57:20 PDT
Oh, ah, yes. Vouching, too.
Comment 13 matthew zeier [:mrz] 2007-09-07 13:47:40 PDT
Your CVS account has been created.  Your CVSROOT should be:

   noguer%gmail.com@cvs.mozilla.org:/l10n

Don't forget to set your CVS_RSH environment variable to 'ssh'.

If you have any problems connecting, let me know.
Comment 14 Quim Perez 2007-11-20 04:30:36 PST
I get a Permission denied error when I try to commit changes.

I have read some bugzillas that have the same problem but I haven't found the solution yet.

when I do

$cvs commit

I get the error

Permission denied (publickey,gssapi-with-mic).
cvs [commit aborted]: end of file from server (consult above messages if any)

I'm sorry but I've never tried to commit since I get the write access to cvs in setember. 

I give you more information about this:


$ ls -ld /home/****/.ssh
drwx------ 2 **** **** 4096 2007-11-20 07:32 .ssh

$ ls -l /home/****/.ssh
-rw-r--r-- 1 **** **** 1423 2007-11-20 07:32 config
-rw------- 1 **** ****  736 2007-11-19 23:05 id_dsa
-rw-r--r-- 1 **** ****  606 2007-11-19 23:05 id_dsa.pub
-rw-r--r-- 1 **** **** 2700 2007-11-20 06:32 known_hosts

$grep Identity /home/****/.ssh/config
   IdentityFile ~/.ssh/id_dsa

$more ...calendar/l10n/ca/CVS/Root
:ext:noguer%gmail.com@cvs.mozilla.org:/l10n

$echo $CVS_RSH
ssh


$ ssh -v  noguer%gmail.com@cvs.mozilla.org

OpenSSH_4.3p2 Debian-8ubuntu1, OpenSSL 0.9.8c 05 Sep 2006
debug1: Reading configuration data /home/****/.ssh/config
debug1: Applying options for *
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug1: Connecting to cvs.mozilla.org [63.245.208.155] port 22.
debug1: Connection established.
debug1: identity file /home/****/.ssh/id_dsa type 2
debug1: Remote protocol version 2.0, remote software version OpenSSH_3.9p1
debug1: match: OpenSSH_3.9p1 pat OpenSSH_3.*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_4.3p2 Debian-8ubuntu1
debug1: Miscellaneous failure
No credentials cache found

debug1: Miscellaneous failure
No credentials cache found

debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-cbc hmac-md5 none
debug1: kex: client->server aes128-cbc hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Host 'cvs.mozilla.org' is known and matches the RSA host key.
debug1: Found key in /home/****/.ssh/known_hosts:9
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,gssapi-with-mic
debug1: Next authentication method: gssapi-with-mic
debug1: Authentications that can continue: publickey,gssapi-with-mic
debug1: Authentications that can continue: publickey,gssapi-with-mic
debug1: Next authentication method: publickey
debug1: Offering public key: /home/****/.ssh/id_dsa
debug1: Authentications that can continue: publickey,gssapi-with-mic
debug1: No more authentication methods to try.
Permission denied (publickey,gssapi-with-mic).


salute
Comment 15 Toni Hermoso Pulido 2007-12-03 05:57:18 PST
Hello,

any advance here?
Comment 16 matthew zeier [:mrz] 2007-12-03 14:17:22 PST
Your ssh key was horribly truncated - fixed.  You should be able to get in now.

Note You need to log in before you can comment on or make changes to this bug.