"Entire message" search fails if charset not known - should use default charset.

RESOLVED DUPLICATE of bug 404255

Status

Thunderbird
Mail Window Front End
--
major
RESOLVED DUPLICATE of bug 404255
10 years ago
7 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

(Blocks: 1 bug, {intl})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.5) Gecko/20070713 Firefox/2.0.0.5
Build Identifier: Thunderbird 2.0.0.5

Doing a "Entire message" search of a word in a message which charset is unknown causes a search failure.

After adding the alias to res/charsetalias.properties, search works.

Note that search in subject/header works fine.

The default charset (or utf-8 or...) should be used when charset is not recognised for searching "entire message".


Reproducible: Always

Steps to Reproduce:
1. Get a message with an unknown charset like "ASCII" (or change the message manually) ; set subject to "hello world" and message body to "hello world"
2. Search "world" with search drop-down list set to "Subject or Sender" => OK
3. Same search in "Entire message" => nothing
Actual Results:  
Search with "Entire message" fails.

Expected Results:  
Any default charset would find the word "world" and provides a search result including the message "hello world".

I set the bug as Major: it made me miss an important message!
This can cause a real problem in some case where you think you didn't receive a message, while you did.

Comment 1

9 years ago
will this also be an issue in the new TB3 search paradigm?

Comment 2

9 years ago
very close to mine bug 404255

Comment 3

9 years ago
Just hit the same problem with the current Thunderbird 2.0.0.19. Searched an hour for a mail that I knew was there but Thunderbird was not able to find. Turned out the problem was it had charset=ascii. This may not be a correct charset, but Thunderbird should deal with unknown charsets anyway - in this case the mail was delivered by Amazon.

For reproducing the problem, find attached a zip archive with 5 test mails which are identical except for the charset. If you search for a word in the message body, like "ragtime", you will only get 4 hits - the one with charset=ascii will not be found!

Comment 4

9 years ago
Created attachment 355147 [details]
test emails for reproducing the bug: test_ascii.eml will not be found
To bugzilla@oui.jp(bug opener) and Christoph Zwerschke:

Local mail folder(POP3 or "Local Folders"? IMAP?
If IMAP, online search? Local(or offline) search?
If IMAP and online search, I think DUPing to Bug 404255 is appropriate action, because Bug 404255 clearly explains issue.

Comment 6

9 years ago
I experienced this with *Local Folders*. You can simply import the 5 eml files in the attached zip file to any local folder (e.g. using ImportExportTool) and then search inside that folder for "ragtime" in the message text. All emails will be found, except the one with charset=ascii, although it also contains "ragtime" in the message text. Note that no non-ascii characters exist or are searched in these emails (different to bug 404255), it's all plain ascii.

Updated

9 years ago
Keywords: intl

Updated

9 years ago
Duplicate of this bug: 479237

Comment 8

8 years ago
Have look into Bug 404255 which is propose to use UTF-8 for online search. Probably we should mark this as dupe

Updated

8 years ago
Blocks: 519202

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 404255
You need to log in before you can comment on or make changes to this bug.