Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Full zooming doesn't work well with SVG

VERIFIED FIXED

Status

()

Core
Layout
VERIFIED FIXED
10 years ago
10 years ago

People

(Reporter: roc, Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph
Bug Flags:
in-litmus +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Visit the URL. Now try to zoom. It doesn't. (Which is too bad, because it would be a great way to show off SVG!)

Comment 1

10 years ago
This is probably the same bug as the SVG dpi scaling one.

Updated

10 years ago
Duplicate of this bug: 389824

Comment 3

10 years ago
(In reply to comment #1)
> This is probably the same bug as the SVG dpi scaling one.
> 
I looked it up: Bug 370006.

Comment 4

10 years ago
Install http://ted.mielczarek.org/code/mozilla/fullpagezoom.xpi or evaluate
this in Firefox's error console to zoom:
top.window.opener.getBrowser().markupDocumentViewer.fullZoom = 1.5

Open http://de.wikipedia.org/wiki/Bild:Svg.svg and zoom in. Note that the svg
image gets larger, but instead of being redrawn at the higher resolution, it
looks like zooming in a bitmap image, with zigzag lines.

Now open just the svg image itself:
http://upload.wikimedia.org/wikipedia/commons/1/15/Svg.svg
Zooming only affects the text "SVG" (zooming in makes it larger).

Most other examples like http://www.croczilla.com/svg/samples/tiger/tiger.svg
doesn't react at all to zooming.

But this one actually gets smaller when zooming in:
http://upload.wikimedia.org/wikipedia/de/e/e2/SVG-Logo.svg
Blocks: 4821, 163068

Comment 5

10 years ago
(In reply to comment #4)
> Open http://de.wikipedia.org/wiki/Bild:Svg.svg and zoom in. Note that the svg
> image gets larger, but instead of being redrawn at the higher resolution, it
> looks like zooming in a bitmap image, with zigzag lines.

You _are_ zooming in a bitmap image. The image on the description page is a png.

> Most other examples like http://www.croczilla.com/svg/samples/tiger/tiger.svg
> doesn't react at all to zooming.

If you zoom out enough they get cut off at the bottom and right edge.

> But this one actually gets smaller when zooming in:
> http://upload.wikimedia.org/wikipedia/de/e/e2/SVG-Logo.svg

This is very strage.

Updated

10 years ago
Depends on: 370006

Comment 6

10 years ago
(In reply to comment #5)

> > But this one actually gets smaller when zooming in:
> > http://upload.wikimedia.org/wikipedia/de/e/e2/SVG-Logo.svg
> 
> This is very strage.
> 

I see this Bug also when using Demo from this Blog 
http://blog.vlad1.com/archives/2007/07/28/149/

Maybe we should file a new Bug, because this one is about fully broken zooming

Reduced testcase for getting smaller when zooming in:

<?xml version="1.0" encoding="UTF-8"?>
<svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" xmlns:svg="http://www.w3.org/2000/svg" id="canvas">

  <rect id="background-rect" x="0%" y="0%" width="100%" height="100%" fill="#aaaaaa"/>

</svg>




Comment 7

10 years ago
Please hold off on filing more bugs about this until Bug 370006 gets fixed.

Comment 8

10 years ago
I can't zoom it either: http://upload.wikimedia.org/wikipedia/commons/9/9d/European_Union_member_states_with_applications.svg
Tim's fix for bug 370006 seems to have fixed this.
OS: Mac OS X → All
Hardware: PC → All

Comment 10

10 years ago
Yes, RESOLVED FIXED. http://upload.wikimedia.org/wikipedia/de/e/e2/SVG-Logo.svg is still showing problems, though. (It doesn't zoom, instead it moves towards the bottom-right corner.) Looks like percentage-sized SVGs cause problems.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Comment 11

10 years ago
I'm using the latest build and when I zoom in (Ctrl-+) or zoom out (Ctrl--) the SVG image size doesn't change, however it moves from left to right or vice versa.
Flags: in-litmus?
https://litmus.mozilla.org/show_test.cgi?id=5203 has been added to Litmus. Also verifying this bug - this works for me using  Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b5pre) Gecko/2008031404 Minefield/3.0b5pre and on the Win XP nightly.
Status: RESOLVED → VERIFIED
Flags: in-litmus? → in-litmus+
You need to log in before you can comment on or make changes to this bug.