full page zoom doesn't work with SVG (doesn't zoom at all, or only text)

RESOLVED DUPLICATE of bug 389769

Status

()

Core
SVG
RESOLVED DUPLICATE of bug 389769
10 years ago
10 years ago

People

(Reporter: Steffen Wilberg, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
Bug 4821 implemented full page zoom for normal webpages. But that doesn't work right with SVG images. Bug 163068 already implemented the SVG backend for zooming, but that's apparently not hooked up for full page zoom.

Install http://ted.mielczarek.org/code/mozilla/fullpagezoom.xpi or evaluate this in Firefox's error console:
top.window.opener.getBrowser().markupDocumentViewer.fullZoom = 1.5

Open http://de.wikipedia.org/wiki/Bild:Svg.svg and zoom in. Note that the svg image gets larger, but instead of being redrawn at the higher resolution, it looks like zooming in a bitmap image, with zigzag lines.

Now open just the svg image itself:
http://upload.wikimedia.org/wikipedia/commons/1/15/Svg.svg
Zooming only affects the text "SVG" (zooming in makes it larger).

Most other examples like http://www.croczilla.com/svg/samples/tiger/tiger.svg doesn't react at all to zooming.

But this one actually gets smaller when zooming in:
http://upload.wikimedia.org/wikipedia/de/e/e2/SVG-Logo.svg

Comment 1

10 years ago
If you could re-add the dependencies over in bug 389769, that would be great.
No longer blocks: 4821, 163068
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 389769
You need to log in before you can comment on or make changes to this bug.