list-item marker disappears when using "position: relative;" [REL POS]

VERIFIED WORKSFORME

Status

()

Core
CSS Parsing and Computation
P3
normal
VERIFIED WORKSFORME
18 years ago
17 years ago

People

(Reporter: Koike Kazuhiko, Assigned: Marc Attinasi)

Tracking

({css2})

Trunk
Future
x86
All
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
list-item marker disappears when using "position: relative;".

<ol>
<li style="position: relative; left: 00px;">Line 1
<li style="position: relative; left: 20px;">Line 2
<li style="position: relative; left: 40px;">Line 3
</ol>
(Assignee)

Comment 1

18 years ago
Yet another relative / absolute positioning bug... (sigh)
Assignee: pierre → attinasi
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

18 years ago
Accepting and assigning milestone.
Status: NEW → ASSIGNED
Target Milestone: --- → M18
(Assignee)

Comment 3

18 years ago
Created attachment 9083 [details]
Testcase: same as the reporter's, as attachment.
(Assignee)

Comment 4

18 years ago
When a LI is abs. or rel. positioned, the frame for the bullets (image or 
numbers) is not even created. 

There are problem in the CSSFrameConstructor: in the positioned cases, the frame 
for the LI is created differently, and in such a way that 
nsBlockFrame::SetInitialChildList is not called, and that is where the bullet 
frame is normally created.

I'm still investigating... If anybody has experience in this area I could use 
some help :-)
Note that as mentioned in another bug, a "display:list-item" frame that is
absolutely positioned, becomes a "display:block" frame and thus loses it's
bullet. I think. Yes, here it is:
   http://www.w3.org/TR/REC-CSS2/visuren.html#q24

Relative positioning is a different matter, the bullet shouldn't go walkabouts 
in that particular case.
Keywords: css2
(Assignee)

Comment 6

18 years ago
This bug has been marked "future" because we have determined that it is not 
critical for netscape 6.0. If you feel this is an error, or if it blocks your 
work in some way -- please attach your concern to the bug for reconsideration.
Target Milestone: M18 → Future
Summary: list-item marker disappears when using "position: relative;" → list-item marker disappears when using "position: relative;" [REL POS]
Depends on: 54979
Netscape's standard compliance QA team reorganised itself once again, so taking 
remaining non-tables style bugs. Sorry about the spam. I tried to get this done 
directly at the database level, but apparently that is "not easy because of the 
shadow db", "plus it screws up the audit trail", so no can do...
QA Contact: chrisd → ian
Nominating
Keywords: mozilla0.9, nsbeta1
*** Bug 68935 has been marked as a duplicate of this bug. ***

Comment 10

17 years ago
position:relative is only one which triggers the appeareance of this bug.

Each of the following makes the list marker to disapear:

position:relative;top:0px;left:120%;width:100%;margin:0px;padding:0px;

This does not affect the list marker:

visibility:hidden;

If you set the visibility afterwards to visible, then the list marker appears.

Updated

17 years ago
Blocks: 104166

Comment 11

17 years ago
The same problem exists when using "padding:" or "padding-left:"

<head>
<style type="text/css">
ol { padding-left: 10pt}
</style>
</head>
<body>
<ol>
<li>Line 1
<li>Line 2
<li>Line 3
</ol>
</body> 

Comment 12

17 years ago
WFM now. 
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 13

17 years ago
Why is this bug target smilestone set to future?
VERIFIED using attachment 9083 [details].
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.