Closed Bug 390214 Opened 12 years ago Closed 12 years ago

avoid the second UAC prompt for helper.exe on software update by launching it directly from the elevated updater.exe process

Categories

(Thunderbird :: Installer, defect)

x86
Windows Vista
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: rstrong, Assigned: rstrong)

References

Details

(Keywords: verified1.8.1.8)

Attachments

(2 files)

Attached patch patchSplinter Review
Thunderbird version of bug 368587
Attachment #274533 - Flags: review?(mscott)
Attachment #274533 - Flags: review?(mscott) → review+
Checked in to trunk

Checking in mozilla/mail/locales/Makefile.in;
/cvsroot/mozilla/mail/locales/Makefile.in,v  <--  Makefile.in
new revision: 1.43; previous revision: 1.42
done
Checking in mozilla/mail/installer/windows/nsis/uninstaller.nsi;
/cvsroot/mozilla/mail/installer/windows/nsis/uninstaller.nsi,v  <--  uninstaller.nsi
new revision: 1.5; previous revision: 1.4
done
RCS file: /cvsroot/mozilla/mail/installer/windows/nsis/updater_append.ini,v
done
Checking in mozilla/mail/installer/windows/nsis/updater_append.ini;
/cvsroot/mozilla/mail/installer/windows/nsis/updater_append.ini,v  <--  updater_append.ini
initial revision: 1.1
done
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Flags: in-litmus?
Comment on attachment 274533 [details] [diff] [review]
patch

Scott, I received approval for 1.8.1.7 for Firefox. Do you want this for Thunderbird as well?
Attachment #274533 - Flags: approval1.8.1.7?
Comment on attachment 274533 [details] [diff] [review]
patch

since this got FX approval, hopefully the triage team won't mind me approving this for tbird too.
Attachment #274533 - Flags: approval1.8.1.7? → approval1.8.1.7+
Checked in to MOZILLA_1_8_BRANCH

Checking in mozilla/mail/locales/Makefile.in;
/cvsroot/mozilla/mail/locales/Makefile.in,v  <--  Makefile.in
new revision: 1.26.2.16; previous revision: 1.26.2.15
done
Checking in mozilla/mail/installer/windows/nsis/uninstaller.nsi;
/cvsroot/mozilla/mail/installer/windows/nsis/uninstaller.nsi,v  <--  uninstaller.nsi
new revision: 1.1.2.6; previous revision: 1.1.2.5
done
Checking in mozilla/mail/installer/windows/nsis/updater_append.ini;
/cvsroot/mozilla/mail/installer/windows/nsis/updater_append.ini,v  <--  updater_append.ini
new revision: 1.1.2.1; previous revision: 1.1
done
Keywords: fixed1.8.1.7
note: the second UAC prompt will still be seen during the next software update and subsequent software updates after the next one should not display the second UAC prompt. See Bug 368587 comment #29 for information on how to verify.
verified fixed 1.8.1.8 using version 2.0.0.7pre (20070830) and version 2.0.0.7pre (20071011) and the steps to reproduce from Bug 368587. 

Results from test steps are the expected one: File: \removed-files File: \softokn3.chk are added to the uninstall.log and RegKeys were changed
You need to log in before you can comment on or make changes to this bug.