Mac-only trunk topcrash at [@ JS_GetGlobalObject]

RESOLVED FIXED in mozilla1.9alpha8

Status

Core Graveyard
Java: Live Connect
--
critical
RESOLVED FIXED
11 years ago
7 years ago

People

(Reporter: Benjamin Smedberg, Unassigned)

Tracking

({regression, topcrash+})

unspecified
mozilla1.9alpha8
x86
Mac OS X
regression, topcrash+
Bug Flags:
blocking1.9 +

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
There was a trunk-only topcrash regression introduced around 7/16 at JS_GetGlobalObject. It seems probably related to liveconnect and maybe JEP:

http://crash-stats.mozilla.com/report/list?range_unit=weeks&branch=1.9&range_value=2&signature=JS_GetGlobalObject
Flags: blocking1.9+

Comment 1

11 years ago
I'm pretty sure this is a dupe of bug 387975, which is supposedly fixed by the new JEP, which is pending review/approval (bug 386918).
> I'm pretty sure this is a dupe of bug 387975,

It's more likely that other factors (as yet unknown) explain both that
bug and this one.

From the timing, clearly _some_ factor external to the JEP is
involved.  Did a new version of Adblock or Adblock Plus appear around
that time?  If so, this would confirm a connection to bug 387975.  But
why was the change so sudden, and why did it only happen on the trunk?

I think the "external factor" is much more likely to be some change in
the browser.  Over the next week or so I'll try to find out what this
might have been.

(By the way, JEP 0.9.6.3 _does_ fix a crash bug that might have caused
(or partially caused) the bad interaction with Adblock Plus, discussed
at 387975.  It's #1 in the JEP change log that I posted at bug 386918
(attachment 271050 [details]).  It's possible the same JEP bug is (partially)
implicated here.  We'll only be able to tell after JEP 0.9.6.3 gets
landed on the trunk.)
Another possible factor is bug 383783, which broke JavaScript-to-Java
LiveConnect -- which seems to be involved in many of these crashes.
But once again the timing is wrong -- bug 383783 was landed on
2007-06-18.  (JEP 0.9.6.3 also works around this problem, which is #2
in my change log at attachment 271050 [details].)

Side note:  I think some of these crash logs are corrupt, and have
nothing at all to do with Java.  For example:

http://crash-stats.mozilla.com/report/index/a6637bd9-3dbd-11dc-9b27-001a4bd46e84
http://crash-stats.mozilla.com/report/index/218170f0-3dbd-11dc-aff0-001a4bd43e5c

Updated

11 years ago
Severity: normal → critical
Summary: Mac-only trunk topcrash at JS_GetGlobalObject → Mac-only trunk topcrash at [@ JS_GetGlobalObject]
JEP 0.9.6.3 was landed on the trunk yesterday, and is in today's
Minefield nightly.  It'll be interesting to see what effect this has
(over the next week or two) on this crash's frequency.
Reports of this problem at comment #0's URL stop dead with the Aug
14th trunk nightly.  This seems to indicate that my JEP 0.9.6.3
upgrade fixed (or worked around) this problem ... whatever it was.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Updated

7 years ago
Component: Java: Live Connect → Java: Live Connect
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.