Last Comment Bug 390313 - Tooltip too narrow with some Windows themes, text is truncated
: Tooltip too narrow with some Windows themes, text is truncated
Status: RESOLVED FIXED
: regression
Product: Calendar
Classification: Client Software
Component: Calendar Views (show other bugs)
: Mozilla 1.8 Branch
: x86 Windows XP
: -- normal with 1 vote (vote)
: 0.9
Assigned To: Stefan Sitter
:
Mentors:
: 401356 450389 (view as bug list)
Depends on: 366680
Blocks: 262811
  Show dependency treegraph
 
Reported: 2007-07-31 09:07 PDT by Markus Adrario [:Taraman]
Modified: 2008-09-01 14:11 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Screenshot of the Tooltip (8.11 KB, image/jpeg)
2007-07-31 09:29 PDT, Markus Adrario [:Taraman]
no flags Details
partial workaround (1.09 KB, patch)
2008-07-24 10:57 PDT, Stefan Sitter
philipp: review+
Details | Diff | Splinter Review
Screenshot of the Tooltip with applied patch (9.96 KB, image/png)
2008-07-24 10:59 PDT, Stefan Sitter
no flags Details

Description Markus Adrario [:Taraman] 2007-07-31 09:07:39 PDT
The Tooltip information does not show the whole descriptive text. The last 1 or 2 characters (depending on character width) of the longest line are missing in all views.
Tested in Lightning on WinXP with TB 2.0.0.5 Portable and Lightning 0.7pre Build 2007073105
Comment 1 Philipp Kewisch [:Fallen] 2007-07-31 09:25:19 PDT
Optionally, this can depend on bug 366680. The patch I have semi-finished totally removes mouseoverPreviews.js, where the tooltip currently lives.
Comment 2 Markus Adrario [:Taraman] 2007-07-31 09:29:33 PDT
Created attachment 274632 [details]
Screenshot of the Tooltip

Here the Time is cut off.
If another line is longer, this gets cut.
Comment 3 Stefan Sitter 2007-08-01 04:33:00 PDT
I can reproduce this issue using Lightning 0.7pre (2007073009) and Thunderbird 2.0.0.6pre (20070730) on Windows 2000.

Markus, do you use a custom theme or extension that could affect the tooltips? I noticed that in your screenshot it has a white background color but during my testing it had a yellow background color.
Comment 4 Stefan Sitter 2007-08-11 15:32:25 PDT
(In reply to comment #3)
> I can reproduce this issue using Lightning 0.7pre (2007073009) and
> Thunderbird 2.0.0.6pre (20070730) on Windows 2000.

Correction: This should read "I can't reproduce this issue".
Comment 5 Omar Bajraszewski 2007-08-24 12:31:55 PDT
(In reply to comment #4)
> I can't reproduce this issue


I can reproduce it with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.7pre) Gecko/20070824 Calendar/0.7pre

The issue isn't present in 0.5 (regression?)---> IMO this bug is really annoying.The tooltip information is not legible. It would be great to have it fixed for final 0.7. So I nominate it for blocking 0.7
Comment 6 Stefan Sitter 2007-09-07 04:56:19 PDT
I now can reproduce it using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.7pre) Gecko/20070906 Calendar/0.7pre. 

The issue depends on the theme used:

Using Windows XP Luna theme -> Fails
Using Windows Classic theme -> Works OK
Comment 7 Markus Adrario [:Taraman] 2007-09-07 09:56:12 PDT
I encountered this bug using the Microsot Zune-Theme.
I'll test it with the classic theme sometime soon.
Comment 8 Markus Adrario [:Taraman] 2007-09-09 10:36:55 PDT
OK, confirmed normal behaviour with standard windows XP-Theme.
So this bug only shows up with other themes.
Comment 9 Stefan Sitter 2007-09-19 14:01:57 PDT
Other tooltip related Bug 396298 and Bug 389341 were regressed between the 2007-07-04-04 and 2007-07-05-04 build. 

Markus, Omar: Can you confirm this regression range? If not: Can you find the correct range?
Comment 10 Omar Bajraszewski 2007-09-20 02:31:37 PDT
(In reply to comment #9)
> Other tooltip related Bug 396298 and Bug 389341 were regressed between the
> 2007-07-04-04 and 2007-07-05-04 build. 
> 
> Markus, Omar: Can you confirm this regression range? If not: Can you find the
> correct range?
> 

Confirmed the regression range
Comment 11 Markus Adrario [:Taraman] 2007-09-23 07:03:08 PDT
I can also confirm the range. Tried with the 1.8 builds
2007-07-04-03 --> OK
2007-07-05-04 --> tooltip too narrow
Comment 12 Omar Bajraszewski 2007-10-27 04:37:18 PDT
*** Bug 401356 has been marked as a duplicate of this bug. ***
Comment 13 Karel Koubek 2007-10-27 04:49:24 PDT
I'm seeing this bug in Sunbird 0.7 with XP Luna theme and find it highly annoying. No problem with Sunbird 0.5.
Comment 14 Lifesaver2000 2008-04-15 07:39:51 PDT
Still present in Lightning 0.8, with TB 2.0.0.12, on Windows XP SP2.  If the "Luna" theme is the default (as in I haven't changed anything since I bought the computer) theme, then that is what I am using.

As mentioned, it is very annoying, and since nearly every non-computer-geek-owned Windows computer I see uses this "theme," then I would imagine a lot of lightning users are seeing this.
Comment 15 Stefan Sitter 2008-07-05 03:41:39 PDT
Fails using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.17pre) Gecko/20080704 Calendar/0.9pre with Windows XP Luna theme.

Works fine using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.2pre) Gecko/2008070318 Calendar/0.6a1 with Windows XP Luna theme.

--> Issue already fixed on TRUNK. Only MOZILLA_1_8_BRANCH is affected.
Comment 16 Stefan Sitter 2008-07-24 10:57:35 PDT
Created attachment 331143 [details] [diff] [review]
partial workaround

This workaround partially fixes the issue with the Luna theme. For example it's now possible to see the full time string. But if the tooltip contains e.g. a wrapped description it is still truncated. Maybe there is some miscalculation regarding max-width when using the Luna theme. 

The patch doesn't seem to have any effect when using the XP classic theme. Therefore I assume it won't cause any side effects on other system/themes with correct tooltip display.
Comment 17 Stefan Sitter 2008-07-24 10:59:03 PDT
Created attachment 331144 [details]
Screenshot of the Tooltip with applied patch
Comment 18 Philipp Kewisch [:Fallen] 2008-08-08 17:58:46 PDT
Comment on attachment 331143 [details] [diff] [review]
partial workaround

Fine with me, r=philipp
Comment 19 Philipp Kewisch [:Fallen] 2008-08-08 17:59:59 PDT
Checked in on HEAD and MOZILLA_1_8_BRANCH

-> FIXED
Comment 20 Stefan Sitter 2008-08-09 02:49:17 PDT
As pointed out in comment #16 this workaround doesn't fix the issue in all cases. I'm not sure if we want to keep the bug open to find another workaround for that cases too. The final fix would be switching to Trunk where this issue doesn't exists.
Comment 21 Philipp Kewisch [:Fallen] 2008-08-09 07:51:34 PDT
Given that we are shortly before the last branch release, I doubt we want to keep this bug open, unless you find a better workaround/fix.

It would be nice to add a comment to those lines that contains MOZILLA_1_8_BRANCH so we can filter out things easier when moving to trunk. I'll add that later on.
Comment 22 Markus Adrario [:Taraman] 2008-08-10 03:52:38 PDT
Also works on XP Zune Theme.
Comment 23 Stefan Sitter 2008-08-23 03:04:41 PDT
*** Bug 450389 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.