Compact all folders for all accounts wanted. Compact Folders acts on only one account.

RESOLVED DUPLICATE of bug 1077759

Status

Thunderbird
Mail Window Front End
--
enhancement
RESOLVED DUPLICATE of bug 1077759
11 years ago
2 years ago

People

(Reporter: Patrik Nilsson, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: Thunderbird v2.0.0.5

Compact folder from the menu just compacts current folder. Instead of having a auto compact option enter "Wasting xx kbyte disk space" on the status bar. The user can choose when to compact all folders. (When the user plan to leave the program for a while.)



Reproducible: Always
(Reporter)

Comment 1

11 years ago
Wanted behavior:

1. User sees "wasting xx kbytes" on the status bar and decides it is too much.
2. User selects "Compact All".
3. A window with a canceling option and a progress slide is shown.
4. The user can wait for the process to complete or cancel it.

During the process Thunderbird doesn't check the mail, feeds, or allows the user to do anything with the program except from canceling the compacting process.

See also bug 390351.

Comment 2

11 years ago
It's already there. File > Compact folders
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

11 years ago
There is no "compact all". Yes, you have "compact", but that function only compacts the CURRENT selected account. If you have several e-mail accounts and RSS accounts, you need to repeat "compact" for each one. Please "Reopen bug", if you agree to my comment.

Comment 4

11 years ago
Ok, reopening, updating summary. But I feel that is more of something for and extension - shouldn't be very hard...
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Summary: Compact All Folders wanted → Compact All Folders For All Accounts wanted
Reporter would you still need this when bug 286888 happens ?
(Reporter)

Comment 6

9 years ago
Not necessarily. If the user use a slow hard disk (I use Acer Aspire One) there can an option for user interaction, as long as data base update is not optimized.

Comment 7

6 years ago
(In reply to Patrik Nilsson from comment #6)
> Not necessarily. If the user use a slow hard disk (I use Acer Aspire One)
> there can an option for user interaction, as long as data base update is not
> optimized.

bienvenu, does bug 286888 or "other storage formats" trump the above?
Whiteboard: [wontfix?]

Comment 8

6 years ago
I thought file menu, compact folders compacts all accounts, not just the current account.

Comment 9

6 years ago
(In reply to David :Bienvenu from comment #8)
> I thought file menu, compact folders compacts all accounts, not just the
> current account.

oh yes, correct - it does.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago6 years ago
Resolution: --- → WORKSFORME
Whiteboard: [wontfix?]

Comment 10

2 years ago
(In reply to Wayne Mery (:wsmwk, NI for questions) from comment #9)
> (In reply to David :Bienvenu from comment #8)
> > I thought file menu, compact folders compacts all accounts, not just the
> > current account.
> 
> oh yes, correct - it does.

No - this is wrong. Only one account is compacted, and is easily proved via testing
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: WORKSFORME → ---
Summary: Compact All Folders For All Accounts wanted → Compact all folders for all accounts wanted. Compact Folders acts on only one account.

Updated

2 years ago
Component: Account Manager → Mail Window Front End

Comment 11

2 years ago
duping forward to bug 1077759, which has more details than this bug
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1077759
You need to log in before you can comment on or make changes to this bug.