Closed Bug 390495 Opened 15 years ago Closed 14 years ago

[Trunk] datepicker combo from calendar tab is expanded after starting thunderbird

Categories

(Calendar :: Lightning Only, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: torindel, Unassigned)

References

()

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1.5) Gecko/20070720 Firefox/2.0.0.5
Build Identifier: TRUNK

datepicker widget is shown after starting thunderbird (look at picture in url) and is positioned directly under datepicker combobox which is on calendar tab (this occurs in non-pre0.7 lightning)due change in thunderbird trunk between 2007-07-04 and 2007-07-05 

Reproducible: Always

Steps to Reproduce:
1.Start thunderbird with lightning installed
this *also* occurs in non-pre0.7 lightning (typo)
(In reply to comment #1)
> this *also* occurs in non-pre0.7 lightning (typo)

Instead of writing "non-pre0.7 lightning" please note the correct Lightning version and Build ID as shown in the Addon-Manager. Please also note the Thunderbird version and Build ID.

It seems that you filed the same issue just a few days ago with Bug 390226.
affect all minicalendar combo-boxes everywhere (e.g. in add new event window after opening dialog window we get couple of such auto expanded on create combo-boxes) (tested on calendar trunk nightly builds from last 2 months) due to change in thunderbird trunk older than 2007-07-05
Last good nightly build thunderbird version: version 3.0a1pre (2007070504)
this bug is caused by https://bugzilla.mozilla.org/show_bug.cgi?id=279703
Works for me using Lightning 0.6a1 (2007080105) with Thunderbird 3.0a1pre (2007080104) on Windows 2000. Datepicker behaves correctly.
tested windows build too and its ok, both my linux build and official nighly linux trunk is affected can someone test on mac?
OS: All → Linux
Summary: datepicker combo from calendar tab is expanded after starting thunderbird → [Trunk] datepicker combo from calendar tab is expanded after starting thunderbird
Confirmed using Thunderbird 3.0a1pre (2007083103) + Lightning 0.6a1 (2007083103) on Ubuntu 7.10. The popup disappears as soon as you click somewhere in the Thunderbird UI.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: qawanted
Similar behavior in all dialogs that use the datepicker control.

Opening the Event dialog causes two datepicker popups (start/end) to be displayed immediately. Opening the task dialog causes three datepicker popups (begin/due/completed) to be displayed immediately. ...
The problems is that minimonth fires an onmonthchange upon initialization. This makes the datepicker think that the minimonth is already displayed and that it needs to apply the reshow hack.

minimonth.constructor() calls minimonth.refreshDisplay() that calls minimonth.showMonth() that always fires the event. This patch suppresses the event the first time showMonth() is called.
Attachment #290033 - Flags: review?(michael.buettner)
Comment on attachment 290033 [details] [diff] [review]
Don't trigger monthchange upon initialization

> The problems is that minimonth fires an onmonthchange
> upon initialization. This makes the datepicker think
> that the minimonth is already displayed and that it
> needs to apply the reshow hack.
Thanks for figuring out...

>+    var monthChanged = this.mEditorDate && (this.mEditorDate != aDate);
Nice and clean patch, thanks again. r=mickey.
Attachment #290033 - Flags: review?(michael.buettner) → review+
patch checked in on trunk and MOZILLA_1_8_BRANCH

-> FIXED
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Setting milestone to 0.8 although it was a trunk only bug because the patch was checked in on HEAD and MOZILLA_1_8_BRANCH.
Target Milestone: --- → 0.8
You need to log in before you can comment on or make changes to this bug.