copy link location copies incorrect url

VERIFIED FIXED in M18

Status

SeaMonkey
UI Design
P2
major
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: Jae Gangemi, Assigned: Chris McAfee)

Tracking

({regression})

Trunk
x86
Linux
regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+])

(Reporter)

Description

18 years ago
it seems that either bogus information is being copied if mozilla is just
started and i immediately try to copy a location.

or - after moving to another page, it copies the link out of the url bar.

perhaps this should be marked as a regression?? b/c i believe that it was
working before we had bug 36374
hi Jae, could you pls add specific steps to reproduce this? were you using a
recent version of the linux build?

btw, did you perchance run into bug 38723; not sure if it's related, tho', but
you never know...
(Reporter)

Comment 2

18 years ago
wow - i'm really sorry about that - it's been one of those days :)



ok - i'm noticing this on the latest nightly (2000051210). here's how to

reproduce after loading mozilla :



1. go to any link location and use the copy link

2. go outside to another window (xterm) and paste it, the last thing that was in

the buffer is pasted.

3. go to a new page by clicking a link and repeat the above process and you will

get the url of the link you just clicked.



this actually may be a problem w/ the reading to and from the clipboard memory

b/c if i try to cut and paste something out of the url bar - it does not work

either.



this is different the 38723 b/c there the copy link location gave that js error

- here it's just copying incorrect information or it's not copying information

at all.



perhaps this is more of the cut and paste functions not working properly?



again, sorry about the lack of info, i seem to have had an all around bad day of

posting bugs. :)

Comment 3

18 years ago
I confirm the existence of this bug.  It's a recent regression: I'm pretty sure
I remember that build 2000050308 didn't have it.
(Reporter)

Comment 4

18 years ago
i'm still seeing this in the nightlies - any chance someone can take a look at
it? it's a pretty bad regression and m16 probably shouldn't be "shipped" w/o
this working. 

Comment 5

18 years ago
Just noting for the sake of completeness that this does not occur on Windows 
2000 using 2000051620.
Confirming, adding keywords, -> XP Toolkit/Widgets.

Gerv
Status: UNCONFIRMED → NEW
Component: XPApps → XP Toolkit/Widgets
Ever confirmed: true
Keywords: nsbeta2, regression

Comment 7

18 years ago
back to xpapps.  I know the clipboard code works, so if there is a problem it
would be in the way people are getting the url
Component: XP Toolkit/Widgets → XPApps
mcafee...?
Assignee: don → mcafee

Comment 9

18 years ago
so i have another bug on this... it might be something sorta my fault...
maybe... looking
(Assignee)

Comment 10

18 years ago
pav is looking, over to him.  Fire back to me
if you need to.
Assignee: mcafee → pavlov

Comment 11

18 years ago
[nsbeta2+]
Whiteboard: [nsbeta2+]

Comment 12

18 years ago
*** Bug 40061 has been marked as a duplicate of this bug. ***

Comment 13

18 years ago
reassigning to mcafee (owner of 40061)
Assignee: pavlov → mcafee

Comment 14

18 years ago
Hmmm, this probably explains what happened to me the other day ...
Priority: P3 → P2
Target Milestone: --- → M18

Comment 15

18 years ago
FWIW, this applies to the "Copy Image Location" option as well.  If xclipboard
is running it does reflect the proper contents, though they aren't reflected
on a paste into another X app.

Comment 16

18 years ago
it isn't that it copies the wrong location...it simply doesn't copy anything.
Whatever you paste after having used "copy link location" is whatever was
previously copied correct.
Which can be for instance the previous URL you visited, since some auto-copying
of that field always happens when changing URL. Or - if you had something else
copied in - for instance from a 3rd party app - and then use "copy link
location" and paste to see what you caught - it will be what you copied with 3rd
party app. The only thing that happens when you use "copy link location" is that
console outputs "Write clipboard to memory". But whatever took place sure
doesn't land anywhere near a clipboard.
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 17

18 years ago
Correct, this wasn't doing anything.
We now copy selection to the clipboard as well, fixed.
verif fixed using opt comm bits 2000.06.02.08.
Status: RESOLVED → VERIFIED

Comment 19

16 years ago
Mass removing self from CC list.

Comment 20

16 years ago
Now I feel sumb because I have to add back. Sorry for the spam.
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.