Large increase in private byte usage after the landing of bug 385393

RESOLVED FIXED

Status

()

RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: ispiked, Unassigned)

Tracking

({perf, regression})

Trunk
x86
Windows XP
perf, regression
Points:
---
Bug Flags:
blocking1.9 ?
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Comment 1

11 years ago
Working Set numbers showed a similar increase

Comment 2

11 years ago
I suspect this related to that decreased number of GC runs, see bug 385393 comment 107. Less GC means that more garbage can be accumulated between runs.

Updated

11 years ago
Duplicate of this bug: 391406
The cause of reduced GC rate is very likely the unit-length string memo-ization change that went in along with the fast native bulk of the patch for bug 385393. The fast native changes should not have affected memory use, at least not in ways that feed back on the GC schedule.

As I said to Jesse, the way JS_MaybeGC tries to assess when to GC is like trying to tell time of day by measuring bathroom visit distribution. We should try to do better, using process data segment size, perhaps.

/be
Created attachment 275859 [details] [diff] [review]
patch to try on that talos setup

Could this be applied to a test build and run against talos?

/be

Comment 6

11 years ago
(In reply to comment #5)
> Created an attachment (id=275859) [details]
> patch to try on that talos setup
> 
> Could this be applied to a test build and run against talos?

This and bug 395828 came up in the perf meeting today. The js_NewStringCopyN call has already been changed to the version in this patch. Any objections to checking a version of this file with the unit string cache turned off? The test perf boxes are busy in maintenance or baseline work.

Comment 7

11 years ago
fixed by bug 395828.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Comment 8

11 years ago
Does that mean this bug wasn't due to a decrease in GC frequency, but to a leak that we failed to diagnose at the time?
Sadly, yes. And a leak that depended on relative address order of certain malloc'ed allocations.

/be

Comment 10

11 years ago
Ok.  Is there a bug on potentially tweaking the GC rate anyway?  Or on changing the strategy so it's not "like trying to tell time of day by measuring bathroom visit distribution"?

Updated

11 years ago
Flags: in-testsuite-
You need to log in before you can comment on or make changes to this bug.